Bug 801247 - ghostscript 8.70-11.el6_2.6 fails to build from source (missing libstdc++)
ghostscript 8.70-11.el6_2.6 fails to build from source (missing libstdc++)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ghostscript (Show other bugs)
6.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 21:58 EST by Kurt Seifried
Modified: 2012-03-08 12:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 06:17:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2012-03-07 21:58:32 EST
Description of problem:

ghostscript 8.70-11.el6_2.6 fails to build from source (missing libstdc++)

Version-Release number of selected component (if applicable):

ghostscript 8.70-11.el6_2.6 

How reproducible:

Always

Steps to Reproduce:

# ls -la /usr/lib64/libstdc++.so                      
ls: cannot access /usr/lib64/libstdc++.so: No such file or directory

/usr/bin/ld: cannot find -lstdc++
collect2: ld returned 1 exit status
make[1]: *** [bin/../sobin/libgs.so.8.70] Error 1
make[1]: Leaving directory `/root/rpmbuild/BUILD/ghostscript-8.70'
make: *** [so] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.D5kdXd (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.D5kdXd (%build)
===========================================================================
However if we add the link for libstdc++.so:

# ls -la /usr/lib64/libstdc++.so*
lrwxrwxrwx. 1 root root     14 Mar  7 19:31 libstdc++.so -> libstdc++.so.6
lrwxrwxrwx. 1 root root     19 Nov 24 16:28 libstdc++.so.6 -> libstdc++.so.6.0.13
-rwxr-xr-x. 1 root root 989840 Aug 24  2011 libstdc++.so.6.0.13

Works ok:

Wrote: /root/rpmbuild/SRPMS/ghostscript-8.70-11.el6.2.6.src.rpm
Wrote: /root/rpmbuild/RPMS/x86_64/ghostscript-8.70-11.el6.2.6.x86_64.rpm
Wrote: /root/rpmbuild/RPMS/x86_64/ghostscript-devel-8.70-11.el6.2.6.x86_64.rpm
Wrote: /root/rpmbuild/RPMS/x86_64/ghostscript-doc-8.70-11.el6.2.6.x86_64.rpm
Wrote: /root/rpmbuild/RPMS/x86_64/ghostscript-gtk-8.70-11.el6.2.6.x86_64.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.y0o12o
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd ghostscript-8.70
+ rm -rf /root/rpmbuild/BUILDROOT/ghostscript-8.70-11.el6.2.6.x86_64
+ exit 0
Comment 2 Tim Waugh 2012-03-08 06:13:38 EST
Works fine here in mock.  The libstdc++.so symlink lives in /usr/lib/gcc/$arch/$ver, not in libdir.
Comment 4 Kurt Seifried 2012-03-08 12:18:14 EST
I built this on a stock RHEL 6.2 VM of my own. The link you mentioned (/usr/lib/gcc/$arch/$ver) exists on it. I tried building on a different VM (essentially the same as first) and it worked. Sorry about the false report. My other VM must be bjorked in some subtle way :P

Note You need to log in before you can comment on or make changes to this bug.