Bug 801300 - missing description of 'ssh key' part in help page and man page for the 'rhc domain alter' command
missing description of 'ssh key' part in help page and man page for the 'rhc ...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 03:40 EST by Meng Bo
Modified: 2013-03-13 00:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 13:37:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-08 03:40:44 EST
Description of problem:
List of commands
  alter             Alter namespace (will change urls).


Version-Release number of selected component (if applicable):
rhc-0.87.8-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1.install latest rhc client
2.run command 'rhc domain -h' 
3.
  
Actual results:
Missing description of changing ssh key in the man page and help page for the 'alter' command. And it will change the ssh key as well.

Expected results:
like the old command's description:
[mengbo@localhost ~]$ rhc-create-domain -h
<......>
  -a|--alter                   Alter namespace (will change urls) and/or ssh key


Additional info:
[mengbo@localhost ~]$ rhc domain alter -n bmeng1dev6
Password: 
OpenShift Express key found at /home/mengbo/.ssh/libra_id_dsa.  Reusing...
Checking ~/.ssh/config
Found dev.rhcloud.com in ~/.ssh/config... No need to adjust
Alteration successful.
Comment 1 Abhishek Gupta 2012-04-02 13:14:13 EDT
The original idea (at the time of designing/implementing the wrapper commands) was to decouple the ssh key alteration from the 'rhc domain alter' command and let the ssh keys be modified by the 'rhc sshkey ...' command alone. 

As we remove the restrictions on having a default key and start treating all keys the same, we should probably treat this issue in a similar manner. I would suggest that 'rhc domain alter' command should only change the namespace and not modify the keys at all (we need to assess backward compatibility issues, though).

Just my two cents based on why I left out any mention of the ssh keys being modified from the command description.
Comment 2 John (J5) Palmieri 2012-04-10 13:37:47 EDT
Closing not a bug since we wish to encourage people to use rhc sshkey to alter sshkeys. The alter command does not modify the ssh key itself but may modify the ssh config file to add the new domain.

Note You need to log in before you can comment on or make changes to this bug.