Bug 801321 - [abrt] blueman-1.21-10.fc16: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
[abrt] blueman-1.21-10.fc16: connection.py:630:call_blocking:DBusException: o...
Status: CLOSED DUPLICATE of bug 746554
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:4504b0338ede410cff81ada1390...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 04:55 EST by javier del cristo
Modified: 2012-04-26 18:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 18:54:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description javier del cristo 2012-03-08 04:55:18 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/blueman-services
event_log:      2012-03-08-06:54:13> Smolt profile successfully saved
executable:     /usr/bin/blueman-services
kernel:         3.2.8-3.fc16.x86_64
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
time:           mar 06 mar 2012 13:28:20 BRT
uid:            1000
username:       javierdelcristo

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 702, in _message_cb
:    retval = candidate_method(self, *args, **keywords)
:  File "<string>", line 2, in SetPluginConfig
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/DBusService.py", line 97, in SetPluginConfig
:    self.Applet.Plugins.SetConfig(plugin, value)
:  File "/usr/bin/blueman-applet", line 257, in SetConfig
:    self.__config.props.applet_plugins = plugins
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/ConfigPlugin.py", line 37, in __setattr__
:    self.__dict__["Config"]().set(key, value)
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/config/Gconf.py", line 81, in set
:    func(BLUEMAN_PATH + self.section + "/" + key, value)
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/config/Gconf.py", line 76, in x
:    self.client.set_list(key, gconf.VALUE_STRING, val)
:TypeError: value should be a string
:
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/services/Network.py", line 251, in pan_support_toggled
:    applet.SetPluginConfig("NMPANSupport", False)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 702, in _message_cb
:    retval = candidate_method(self, *args, **keywords)
:  File "<string>", line 2, in SetPluginConfig
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/DBusService.py", line 97, in SetPluginConfig
:    self.Applet.Plugins.SetConfig(plugin, value)
:  File "/usr/bin/blueman-applet", line 257, in SetConfig
:    self.__config.props.applet_plugins = plugins
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/ConfigPlugin.py", line 37, in __setattr__
:    self.__dict__["Config"]().set(key, value)
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/config/Gconf.py", line 81, in set
:    func(BLUEMAN_PATH + self.section + "/" + key, value)
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/config/Gconf.py", line 76, in x
:    self.client.set_list(key, gconf.VALUE_STRING, val)
:TypeError: value should be a string
:
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x1b12050>
:args: ('NMPANSupport', False)
:utf8_strings: False
:bus_name: 'org.blueman.Applet'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/'
:timeout: -1.0
:signature: u'sb'
:dbus_interface: 'org.blueman.Applet'
:message: <dbus.lowlevel.MethodCallMessage object at 0x1832f78>
:method: 'SetPluginConfig'

smolt_data:
:
:
:General
:=================================
:UUID: 2832af7d-c4aa-43eb-9183-c2d232200846
:SO: Fedora release 16 (Verne)
:Nivel de ejecución por defecto: Unknown
:Idioma: es_ES.utf8
:Plataforma: x86_64
:BogoMIPS: 4257.17
:Fabricante de CPU: GenuineIntel
:Modelo de CPU: Intel(R) Core(TM) i3 CPU       M 330  @ 2.13GHz
:Paso del UCP: 2
:Familia de UCP: 6
:Número de Modelo de CPU: 37
:Número de CPUs: 4
:Velocidad del CPU: 2133
:Memoria del Sistema: 3818
:Intercambio (swap) del Sistema: 5855
:Vendedor: Dell Inc.
:Sistema: Inspiron 1564 A13
:Factor de forma: Portable
:Kernel: 3.2.9-1.fc16.x86_64
:SELinux Habilitado: 1
:Política de SELinux: targeted
:SELinux Obligado: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:4136:1076) pci, None, HOST/PCI, Core Processor DRAM Controller
:(32902:69:4136:1076) pci, pcieport, PCI/PCI, Core Processor PCI Express x16 Root Port
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(5348:17173:4136:12) pci, wl, NETWORK, Wireless 1397 WLAN Mini-Card
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:4136:1076) pci, None, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15145:4136:1076) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15113:4136:1076) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(4098:38226:4136:1076) pci, radeon, VIDEO, M92 LP [Mobility Radeon HD 4300 Series]
:(4098:43576:4136:1076) pci, snd_hda_intel, MULTIMEDIA, RV710/730
:(32902:15164:4136:1076) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:9288:4136:1076) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15204:4136:1076) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:15170:4136:1076) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4136:1076) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15190:4136:1076) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15156:4136:1076) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15180:4136:1076) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 6
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(4332:33078:4136:1076) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:
:
:Información relacionada con el sistema de archivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_javier-lv_root / ext4 4096 4096 13081819 6559037 5903677 3276800 2697689 2697689
:/dev/sda2 /boot ext4 1024 1024 508745 434210 408610 128016 127790 127790
:/dev/mapper/vg_javier-lv_home /home ext4 4096 4096 63332473 40952681 37782377 15851520 15820331 15820331
:
Comment 1 kashyap 2012-03-15 05:58:36 EDT
Reproducing it is quite simple. I went to "Locat services" and enabled Group network & PAN. I also have kde bluedevil running.

Package: blueman-1.21-10.fc16
OS Release: Fedora release 16 (Verne)
Comment 2 Mr. Meval 2012-04-15 14:58:37 EDT
Activated blueman to contol dun on local services. 

Package: blueman-1.21-10.fc16
OS Release: Fedora release 16 (Verne)
Comment 3 Christoph Wickert 2012-04-26 18:54:20 EDT

*** This bug has been marked as a duplicate of bug 746554 ***

Note You need to log in before you can comment on or make changes to this bug.