Bug 801324 - virt-v2v ignores spice directives in guest XML definition
virt-v2v ignores spice directives in guest XML definition
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 05:01 EST by Marko Myllynen
Modified: 2014-11-18 06:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 06:12:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-03-08 05:01:46 EST
Description of problem:
When converting a VMware RHEL 6 guest with virt-v2v by

# qemu-img convert -p -O qcow2 /tmp/virtual-rhel.vmdk /var/lib/libvirt/images/virtual-rhel.img
# virsh --connect qemu:///system pool-refresh default
# virt-v2v -i libvirtxml -os default /tmp/virtual-rhel.xml

using the following in the guest XML definition

...
<channel type='spicevmc'>
  <target type='virtio' name='com.redhat.spice.0'/>
  <address type='virtio-serial' controller='0' bus='0' port='1'/>
</channel>
<graphics type='spice' autoport='yes'/>
<video>
  <model type='qxl' vram='65536' heads='1'/>
  <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
</video>
...

the guest correctly appears in virt-manager but when inspecting the guest HW
details, display is VNC and video is Cirrus.

Version-Release number of selected component (if applicable):
RHEL 6.2
Comment 2 yuping zhang 2012-03-08 10:02:00 EST
There is a bug 665958 exist for this issue:The display type will always become VNC.
Comment 3 RHEL Product and Program Management 2012-05-03 01:21:13 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Richard W.M. Jones 2014-11-18 06:12:22 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.