Bug 801356 - [RHEL]RHEV-Management Agents-Multipath error
[RHEL]RHEV-Management Agents-Multipath error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Ben Marzinski
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 06:01 EST by Michael
Modified: 2012-08-23 17:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 17:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (68.94 KB, application/octet-stream)
2012-03-08 06:01 EST, Michael
no flags Details
install log (26.56 KB, application/octet-stream)
2012-03-08 06:01 EST, Michael
no flags Details
messages (239.54 KB, application/octet-stream)
2012-03-08 06:02 EST, Michael
no flags Details
mulitipath -v2 (66 bytes, application/octet-stream)
2012-03-08 06:02 EST, Michael
no flags Details
multipath -v3 (4.13 KB, application/octet-stream)
2012-03-08 06:02 EST, Michael
no flags Details

  None (edit)
Description Michael 2012-03-08 06:01:06 EST
Created attachment 568591 [details]
dmesg

Description of problem:

I install a new RHEL 6.2 server with default configuration. Than i register that on redhat and put the chanel: rhel-x86_64-rhev-mgmt-agent-6

Than i update this with yum update.

After reboot i make follow of the rhev install manual:
"8.1. Adding Red Hat Enterprise Linux Hosts"

After that i add this to rhevm in the gui. Rhevm install this hosts and after reboot i become at login screen a lot of follow errors:

device-mapper: table: 253:0: multipath: error getting device

My server is a Dell R415

How reproducible:

That same that i have wirite under Description.


Steps to Reproduce:
1.Install and update RHEL 6.2
2.Add this to rhevm gui
3.Reboot
Comment 1 Michael 2012-03-08 06:01:31 EST
Created attachment 568592 [details]
install log
Comment 2 Michael 2012-03-08 06:02:02 EST
Created attachment 568593 [details]
messages
Comment 3 Michael 2012-03-08 06:02:27 EST
Created attachment 568594 [details]
mulitipath -v2
Comment 4 Michael 2012-03-08 06:02:54 EST
Created attachment 568595 [details]
multipath -v3
Comment 6 Ben Marzinski 2012-03-12 18:49:20 EDT
I'm not sure why the device is trying to load so many times, but it looks like it's failing because the device is in-use. The device that is already in use is /dev/sda.  Is this devices supposed to be multipathed.  I assume that it is the root device.  If so, you will need to remake the initramfs, so that multipath can
access this device before it gets mounted.  However, it looks like there is only one path. In this case, I assume that you don't want this device multipathed. In that case, you need to add

blacklist {
        wwid "3600508e00000000013574a8cfbafd40c"
}

to /etc/multipath.conf

this will keep multipath from trying to use this device.
Comment 7 Ben Marzinski 2012-04-10 10:56:18 EDT
Is this still an issue for you?
Comment 8 Michael 2012-04-24 11:33:45 EDT
No, i have fixed this with a manual blacklist configuration. 

But this can be a problem for other people, that install this automaticaly over the rhev-m gui.
Comment 9 Michael 2012-04-25 05:20:11 EDT
I change the status to low.
Comment 12 Ben Marzinski 2012-08-02 16:45:58 EDT
So, multipath seems to be acting as designed. If have a multipath configuration file, and you do not blacklist a device, it is assumed to be whitelisted.  This bug should either be closed NOTABUG, or it should get moved to the rhev-m gui, which should handle dealing with the configuration file.

Note You need to log in before you can comment on or make changes to this bug.