Bug 801395 - build failure, undefined reference to `__builtin_iroundf'
build failure, undefined reference to `__builtin_iroundf'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libffado (Show other bugs)
rawhide
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 07:46 EST by Karsten Hopp
Modified: 2013-02-07 10:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 10:30:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-03-08 07:46:48 EST
Description of problem:
libffado fails to build on ppc64, but builds on ppc:
g++ -o src/test-debugmodule -Wl,-soname=libffado.so.2 src/debugmodule/test_debugmodule.o -Lsrc -lffado -lm -lrt -lpthread -liec61883 -lraw1394 -lconfig++ -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lglib-2.0
g++ -o src/test-cyclecalc -Wl,-soname=libffado.so.2 src/libieee1394/test-cyclecalc.o -Lsrc -lffado -lm -lrt -lpthread -liec61883 -lraw1394 -lconfig++ -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lglib-2.0
g++ -o src/test-unittests-util -Wl,-soname=libffado.so.2 src/libutil/unittests.o -Lsrc -lffado -lm -lrt -lpthread -liec61883 -lraw1394 -lconfig++ -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lglib-2.0
src/libffado.so: undefined reference to `__builtin_iroundf'
collect2: error: ld returned 1 exit status


Version-Release number of selected component (if applicable):
libffado-2.1.0-0.5.20111030.svn2000.fc17

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f17 libffado-2.1.0-0.5.20111030.svn2000.fc17.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=421603
Comment 1 Brendan Jones 2012-03-08 15:05:31 EST
I removed -ffast-math and was able to build successfully, but I'm sure it is there for a reason.

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=422731
Comment 2 Karsten Hopp 2013-02-07 10:30:51 EST
Works for me, I'll close this.

Note You need to log in before you can comment on or make changes to this bug.