Bug 801492 - Modify kabi-yum-plugins to abort kernel upgrades on kABI concern
Modify kabi-yum-plugins to abort kernel upgrades on kABI concern
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kabi-yum-plugins (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Oros
Release Test Team
:
Depends On:
Blocks: 1296180 1394638 1404314
  Show dependency treegraph
 
Reported: 2012-03-08 11:25 EST by Jon Masters
Modified: 2016-12-13 22:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 05:25:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Masters 2012-03-08 11:25:29 EST
Description of problem:

If a kernel upgrade affects kABI used by a driver update in a negative fashion, optionally (default to on?) abort the upgrade of the kernel and allow resolution of the problem.
Comment 2 Jon Masters 2013-03-25 09:40:48 EDT
Clarification: Cover the case of two kernels together providing the total kABI needed by a module but neither individually satisfying the dependencies required of the module. The module (silently) won't be used today, but the install won't fail in an obvious fashion, and this could be a serious problem.
Comment 3 Ludek Smid 2014-06-26 06:42:43 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.
Comment 4 Ludek Smid 2014-06-26 07:14:17 EDT
The comment above is incorrect. The correct version is bellow.
I'm sorry for any inconvenience.
---------------------------------------------------------------

This request was NOT resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you need
to escalate this bug.
Comment 5 Stanislav Kozina 2016-11-10 05:25:22 EST
Currently, all the Driver Update rpm packages specifically depends on the symbol versions they needed which are provided by the kernel.
The kernel update is still possible (because multiple kernels can be installed at the same time), by the weak-updates script takes care that the incompatible modules are not linked to the kernel modules weak-updates directory.

Very often we need to maintain this situation when a RHEL-7.2 kernel + DUP is installed alongside a RHEL-7.3 GA kernel, which contains the required driver code but might be incompatible with the old DUP.

Thus closing this bug.

Note You need to log in before you can comment on or make changes to this bug.