Bug 8015 - The root password is not recognized, I'm locked out.
The root password is not recognized, I'm locked out.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-27 13:55 EST by williamsmnd
Modified: 2015-01-07 18:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 18:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description williamsmnd 1999-12-27 13:55:41 EST
After carefully installing the Linux Server a sconf time taking care to
write down the root password, I complete the installation successfully and
attempt to go to the root using "su" and am prompted for the root
password.  I enter the root password, (being careful to use the same case
as the password was set during installation), and I recieve "incorrect
root password".  I am now on my third attempt at installing Redhat Linux
6.1 and am just about to send this hacker OS back to you people.  (This is
me venting about a product that was "acclaimed").  I should have stayed
with Windows NT.
Comment 1 Riley H Williams 1999-12-28 13:36:59 EST
Have you checked that you have the same setting for the CAPS LOCK key both when
setting the password and when trying to use it? A simple test for this is to
install using an entirely numeric password entered with the digit keys at the
top of the main keyboard (ie, NOT using the numeric keypad).

Also, what happens if you try to log in directly as root, rather than logging in
as somebody else and then using su?

All I can say for certain is that in over 100 installs I've done to date, I've
NEVER seen the problem you refer to other than (a) having CAPS LOCK on when
entering the password, or (B) a configuration problem with su.
Comment 2 Riley H Williams 2000-01-18 09:59:59 EST
I've seen this occur under one other circumstance, which appears to be a bug in
the install scripts...

 1. Install RedHat Linux - any from 5.1 onwards will do.

 2. As part of the install, enter a root password as requested. Assume
    the password entered is DUMBO all in upper case.

 3. Find reason to use BACK to step through to before the root password
    entry screen. I had to do so recently.

 4. On going through the install, re-encounter the screen asking for a
    root password, so re-enter the root password. Again, assume DUMBO
    is entered all in upper case.

 5. BOOM !!!

If this has taken place, the resulting root password is DUMBODUMBO rather than
DUMBO as expected.

It appears that when the root password screen is displayed, the previously
entered password is remembered, but no indication of this fact is given. As a
result, the password produced is the concatenation of the passwords entered, in
the order they were entered. This can be verified by entering different
passwords on different runs through that screen.
Comment 3 Jay Turner 2000-02-09 21:55:59 EST
There are a couple of things which could be going on here.  One is the thing
that you mentioned, although I have never experienced the previous entry in the
root password field being retained on a return trip to the screen.  Another
thing which could be going on is that in the installer prior to the latest one
available in RawHide, the user was prompted for a keyboard, but that keyboard
was not loaded into the X, so when the user entered the password in the GUI
mode, the keymap was not loaded, so there was a good chance that the password
would differ once the user rebooted the machine and the correct keymap was
indeed loaded.  This problem is fixed in the latest  installer.

Question, where were you typing "su" to get into the root account?
Comment 4 Riley H Williams 2000-02-14 19:06:59 EST
As regards the keyboard problem, I select the UK keyboard, and the root password
I was trying to set up consisted entirely of lower case letters and digits. As
far as I know, the position of those is identical between the UK and (default)
US keyboards, so I would have to consider that unlikely.

As for entering "su" to get a root account, I wasn't. If you read what I wrote
CAREFULLY, you will note that after I had entered the desired root password on
the screen that asks for it, I had backstepped to before it, then met it again
when stepping forward from where I'd stepped backwards to.

Since on the second pass through it, I had seen no sign that it had remembered
the password I had entered the first time, I naturally entered it again. If I'm
reading it right, then if I'd left those fields blank the second time through,
it would have used the correct password instead of the doubled one it did in
fact use.
Comment 5 Riley H Williams 2000-02-14 19:09:59 EST
One other comment - I said "any from 5.1 will do" in my original message because
the same bug occurs in both 5.1 and 6.1, and I am therefore assuming that it
also occurs in 5.2 and 6.0 - I haven't tried either.

I have never used RedHat prior to 5.1, so can't comment on earlier ones.
Comment 6 Jay Turner 2000-02-16 08:21:59 EST
rhw: if you will read carefully, the person that originally opened the bug says,
'attempt to go to the root using "su"' . . . this is why I am asking where "su"
was typed from.
Comment 7 Riley H Williams 2000-02-16 13:03:59 EST
jturner: My reading of the situation as described by the reporter is that the
root password set by the installation was not the one (s)he thought it was, and
that was why (s)he was unable to "su" with it. Nobody asked whether (s)he was
able to log in normally as root, so I may have misunderstood the situation.

williamsmnd: Can you actually log in as root after installing, or is that
affected as well?

As regards the comments I made re a similar situation I had met, it made no
difference whether I used "su" or tried to log in normally - either way, I had
to enter the doubled password to do so, and not the one I had set.
Comment 8 Jay Turner 2000-02-22 15:27:59 EST
Text mode should print "*" for password characters so that users can tell they
are adding to the existing passwords.
Comment 9 Riley H Williams 2000-02-23 15:18:59 EST
Should do, maybe, but it didn't and still doesn't.
Comment 10 Brock Organ 2000-05-09 19:00:59 EDT
verified from rhw's earlier notes:

using TUI mode in 6.2; enter an initial passwd & confirm (such as BIGDUMBO, it
needs to be at least 6 chars); advance install screens, then back to before
passwd screen; enter passwd screen; TUI passwd fields are blank, so reenter
passwd & confirm BIGDUMBO; continue through install; upon reboot your login for
root is BIGDUMBOBIGDUMBO ...

this isn't a problem using GUI, as the asterisks are clearly visible in the
proper fields...
Comment 11 Michael Fulbright 2000-09-19 18:34:14 EDT
This should be addressed in the Pinstripe beta.

Note You need to log in before you can comment on or make changes to this bug.