Bug 801542 - Kernel panic happens with AMD Southern Islands graphics
Kernel panic happens with AMD Southern Islands graphics
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Jaroslav Kysela
Red Hat Kernel QE team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 13:52 EST by jammy.zhou
Modified: 2015-10-04 14:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 14:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jammy.zhou 2012-03-08 13:52:07 EST
Description of problem:
With AMD Southern Islands graphics card, kernel panic happens randomly with high frequency

Version-Release number of selected component (if applicable):


How reproducible:
Frequently

Steps to Reproduce:
1. Install fresh RHEL 6.2 OS with old graphics card
2. Replace the graphics card with latest Southern Island graphics card
3. Boot the system
  
Actual results:
The 3 popular scenarios during attempt to boot OS (at terminal, before start X):
1. Hangs at "Waiting for 2 sda-like device(s)"
2. Hangs with a lot of errors, such as "[<ffffff8100b0f2>] ? system)call_fastpath...."
3. Hangs with error message "Cut-off screen here" with corruption of RedHat 6.2 on the background.

Expected results:
The system should boot successfully without problem

Additional info:
After some investigation, the problem is related to the ALSA driver support for Southern Islands HDMI. And after upgrade the ALSA driver from 1.0.21 to 1.0.25, the problem disappears
Comment 2 RHEL Product and Program Management 2012-05-03 01:29:42 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Jaroslav Kysela 2012-09-13 11:47:53 EDT
I believe that this issue is resolved in RHEL 6.3.
Comment 4 jammy.zhou 2013-03-04 02:14:39 EST
It looks like that the ALSA driver version is still 1.0.21 by running "cat /proc/asound/version".
Comment 5 jammy.zhou 2013-03-04 02:26:45 EST
So does it mean that the ALSA patches (mentioned in comment#7 of https://bugzilla.redhat.com/show_bug.cgi?id=743622) were ported to RHEL 6.3/6.4 without bumping up the ALSA driver version?
Comment 6 John Shortt 2015-10-04 14:32:05 EDT
This is quite old and several minor versions have released with updates.  If you believe this is still a problem and you can revalidate using RHEL6.7, please reopen or submit a new BZ.

Thanks

Note You need to log in before you can comment on or make changes to this bug.