Bug 801620 - GtkBuilder loading issue
GtkBuilder loading issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk2 (Show other bugs)
6.3
Unspecified All
unspecified Severity high
: rc
: ---
Assigned To: Cosimo Cecchi
Desktop QE
:
Depends On:
Blocks: 795437 804307
  Show dependency treegraph
 
Reported: 2012-03-08 20:49 EST by Marc-Andre Lureau
Modified: 2013-04-30 18:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: gtk2-2.18.9-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gtk2 patch fixing issue (18.33 KB, patch)
2012-03-08 20:49 EST, Marc-Andre Lureau
no flags Details | Diff
gtk2 backported patch fixing issue (2.18 KB, patch)
2012-03-08 20:54 EST, Marc-Andre Lureau
no flags Details | Diff
gtk2 patch with test (28.54 KB, patch)
2012-03-08 20:55 EST, Marc-Andre Lureau
no flags Details | Diff

  None (edit)
Description Marc-Andre Lureau 2012-03-08 20:49:59 EST
Created attachment 568792 [details]
gtk2 patch fixing issue

Description of problem:

accel_path aren't correctly registered when loading builder files.

See attached example patch against gtk2 that should run a simple UI with a customzied key-binding for view/fullscreen menu bound to shift-f8.

Version-Release number of selected component (if applicable):

2.18.9-9

Actual results:

The customized keybinding is missing.

Expected results:

The keybinding should be working

Additional info:

The bug has been fixed in upstream and identified as commit (back ported patch attached)

commit a5b92540d039a3246db3f33842a363f3ce127c48
Author: Juan Pablo Ugarte <juanpablougarte@gmail.com>
Date:   Wed Jun 29 11:45:33 2011 -0300

    Make GtkBuilder do not delay construct properties that can be resolved
    (so construct is respected when possible) and skip construct only props that
    can not.
Comment 2 Marc-Andre Lureau 2012-03-08 20:54:14 EST
Created attachment 568793 [details]
gtk2 backported patch fixing issue
Comment 3 Marc-Andre Lureau 2012-03-08 20:55:34 EST
Created attachment 568794 [details]
gtk2 patch with test

This is just a patch for testing, not for gtk :)
Comment 5 Marc-Andre Lureau 2012-03-09 14:00:52 EST
To verify that bug, start "virt-viewer -w foo" (virt-viewer 0.5.2)

Menu View/Fullscreen:
- doesn't have keybinding before fix
- has F11 keybinding after
Comment 6 Bill Sanford 2012-03-09 15:22:31 EST
Also you need the libvirt-0.9.10-4 installed.
Comment 7 Cosimo Cecchi 2012-03-09 16:17:47 EST
Built gtk2-2.18.9-10.el6 with a fix for this.
Comment 11 errata-xmlrpc 2012-06-20 08:58:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0809.html

Note You need to log in before you can comment on or make changes to this bug.