Bug 801626 - watch: enable ANSI colors in output with "--color"
watch: enable ANSI colors in output with "--color"
Status: CLOSED DUPLICATE of bug 820180
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 21:47 EST by Jan Pokorný
Modified: 2016-01-31 20:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 14:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-03-08 21:47:22 EST
I've noticed a bit annoying thing (compared to other distros)
that watch in F16 still does not recognize "--color" option:

        $ rpm -qf $(which watch)
        procps-3.2.8-24.20110302git.fc16.x86_64
        $ watch --version
        0.2.0
        $ watch --color
        watch: unrecognized option '--color'

On Debian, this seems to work for 2 years already:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=129334

Please fix.
Comment 1 Jan Pokorný 2012-07-27 07:41:06 EDT
Seems to be postponed to F18 with procps-ng package [1]:

> watch: interpret ANSI color code sequences

[1] http://fedoraproject.org/wiki/Features/procps-ng
Comment 2 Jan Pokorný 2012-07-27 07:45:26 EDT
Indeed, using separate RPM [2]:

$ watch --version
watch from procps-ng 3.3.2
$ watch --help | grep color
  -c, --color            interpret ANSI color sequences

[2] http://jcapik.fedorapeople.org/files/procps-ng/f17/
Comment 3 Jaromír Cápík 2012-07-27 14:46:05 EDT
Ahoj Honzo.

Please, read the following bug history ...

https://bugzilla.redhat.com/show_bug.cgi?id=820180

I'm closing this one as duplicate ...

Regards,
Jaromir.

*** This bug has been marked as a duplicate of bug 820180 ***

Note You need to log in before you can comment on or make changes to this bug.