Bug 801639 - HP Touchpad right click is buggy
HP Touchpad right click is buggy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 815046 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 23:27 EST by Samuel Cavazos
Modified: 2012-07-23 22:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-drv-synaptics-1.6.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 00:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (49.13 KB, text/plain)
2012-04-19 23:32 EDT, Samuel Cavazos
no flags Details
xorg.9.log (36.19 KB, text/plain)
2012-04-19 23:33 EDT, Samuel Cavazos
no flags Details
evemu (10.75 KB, application/zip)
2012-04-20 00:01 EDT, Samuel Cavazos
no flags Details
xorg.log in HP ProBook 4520s (98.68 KB, text/x-log)
2012-04-20 07:17 EDT, Juan Orti
no flags Details

  None (edit)
Description Samuel Cavazos 2012-03-08 23:27:38 EST
Description of problem:
An HP-Touchpad with on/off button is hard to use. In order to right click, you must left click using two fingers and drag slightly.  The right button on the mouse is simply a second left click button.

How reproducible:
100%

Steps to Reproduce:
1. Try to use right click button. 
  
Actual results:
Left Clicks. (tedious right click solution described in description.)

Expected results:
Right click, such as bring a menu up.

Additional info:

Am using a pavilian dm4-1265dx with fedora 16, kernel version 3.2.9-1.fc16.x86_64. This problem has been consistent since the release of fedora 15. Not sure if it worked with older versions of fedora.
Comment 1 Samuel Cavazos 2012-04-05 02:36:54 EDT
Bug is worse on Fedora 17 with kernel-3.3.0-8.fc17.x86_64. The same method to right click as on Fedora 15 and 16 does not work anymore.
Comment 2 Peter Hutterer 2012-04-19 23:10:29 EDT
Please attach your xorg.log and an evemu description of the device. thanks.
Comment 3 Samuel Cavazos 2012-04-19 23:32:10 EDT
Im pretty new at this sorry. I am attaching the xorg.log files, but what is an evemu?
Comment 4 Samuel Cavazos 2012-04-19 23:32:52 EDT
Created attachment 578849 [details]
Xorg.0.log
Comment 5 Samuel Cavazos 2012-04-19 23:33:22 EDT
Created attachment 578850 [details]
xorg.9.log
Comment 6 Peter Hutterer 2012-04-19 23:51:03 EDT
rpm is utouch-evemu, some info is here: http://people.freedesktop.org/~whot/evemu/
Comment 7 Samuel Cavazos 2012-04-20 00:00:36 EDT
Here you go. Thanks.
Comment 8 Samuel Cavazos 2012-04-20 00:01:02 EDT
Created attachment 578854 [details]
evemu
Comment 10 Samuel Cavazos 2012-04-20 00:06:21 EDT
xorg-x11-drv-synaptics is up to date. Problem still there though.
Comment 11 Juan Orti 2012-04-20 07:16:34 EDT
I'm experiencing the same problem with a HP ProBook 4520s in F16 x86_64

Relevant package versions:
kernel-3.3.2-1.fc16.x86_64
xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
Comment 12 Juan Orti 2012-04-20 07:17:58 EDT
Created attachment 578963 [details]
xorg.log in HP ProBook 4520s
Comment 13 Juan Orti 2012-04-20 07:21:12 EDT
Similar bug report in Ubuntu: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/710335
Comment 14 Samuel Cavazos 2012-04-20 10:27:26 EDT
Sorry, I was on xorg-x11-drv-synaptics-1.5.99.903-2. I update to the package xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64. Problem seems to be resolved in this package.
Comment 15 Samuel Cavazos 2012-04-20 10:29:09 EDT
Sorry, what I meant to say is that the problem is solved in  xorg-x11-drv-synaptics-1.5.99.903-3 NOT xorg-x11-drv-synaptics-1.5.99.903-2.
Comment 16 Fedora Update System 2012-04-22 19:15:12 EDT
xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-6229/xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17
Comment 17 Fedora Update System 2012-04-24 01:54:07 EDT
xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17
Comment 18 Fedora Update System 2012-04-25 00:47:23 EDT
Package xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6568/xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-04-26 19:42:04 EDT
xorg-x11-drv-synaptics-1.5.99.904-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.904-1.fc17
Comment 20 Fedora Update System 2012-05-02 18:49:01 EDT
xorg-x11-drv-synaptics-1.6.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.0-1.fc17
Comment 21 Fedora Update System 2012-05-07 00:16:05 EDT
xorg-x11-drv-synaptics-1.6.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Samat 2012-05-28 03:26:01 EDT
What about fedora 16?

How can I fix this issue?
Comment 23 Peter Hutterer 2012-07-23 22:14:04 EDT
*** Bug 815046 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.