Bug 801659 - ddate missing from util-linux builds
ddate missing from util-linux builds
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng (Show other bugs)
6.4
All All
unspecified Severity low
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 00:53 EST by Alexander von Gluck IV
Modified: 2012-03-09 05:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 05:21:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander von Gluck IV 2012-03-09 00:53:23 EST
Description:
ddate is missing from util-linux. ddate has been around since the beginning of util-linux and its absence can cause compatibility issues. 

Additional info:
* ddate was removed from the default build by Karel Zak via:
https://git.kernel.org/?p=utils/util-linux/util-linux.git;a=commit;h=4a8962f3a7cb970b28add7d770528edebbe03635
* Debian has already fixed it being missing via:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650321

Solution:
* Add --enable-ddate to util-linux config options.

There are several people working with the util-linux folks to try and get this core system app re-added.
Comment 2 Karel Zak 2012-03-09 05:21:12 EST
I guess that RHEL6 is not the right product for this bug report.

Anyway, ddate has been officially removed from Fedora:
http://lists.fedoraproject.org/pipermail/devel/2011-August/156159.html

... this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.