Bug 801693 - [abrt] evolution-3.2.3-1.fc16: _int_free: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.2.3-1.fc16: _int_free: Process /usr/bin/evolution was kill...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:8600c9b6b62f5ddca6c11e48a84...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 02:26 EST by Dagan McGregor
Modified: 2012-03-12 06:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 06:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: gconf_subtree (13.96 KB, text/plain)
2012-03-09 02:26 EST, Dagan McGregor
no flags Details
File: build_ids (7.21 KB, text/plain)
2012-03-09 02:26 EST, Dagan McGregor
no flags Details
File: dso_list (19.17 KB, text/plain)
2012-03-09 02:26 EST, Dagan McGregor
no flags Details
File: maps (89.59 KB, text/plain)
2012-03-09 02:26 EST, Dagan McGregor
no flags Details
File: backtrace (149.25 KB, text/plain)
2012-03-09 02:26 EST, Dagan McGregor
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 650685 None None None Never

  None (edit)
Description Dagan McGregor 2012-03-09 02:26:06 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        evolution
crash_function: _int_free
executable:     /usr/bin/evolution
kernel:         3.2.7-1.fc16.x86_64
pid:            1910
pwd:            /home/ardrigh
reason:         Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
time:           Mon 27 Feb 2012 12:40:23 NZDT
uid:            1000
username:       ardrigh

backtrace:      Text file, 152837 bytes
build_ids:      Text file, 7380 bytes
dso_list:       Text file, 19625 bytes
gconf_subtree:  Text file, 14293 bytes
maps:           Text file, 91740 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=tighnacheo.pro.local
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=70d6d4657ed21f4c5153faef00000032-1330299548.349038-1444304140
:GNOME_KEYRING_CONTROL=/tmp/keyring-L3A7Hp
:IMSETTINGS_MODULE=none
:USER=ardrigh
:USERNAME=ardrigh
:MAIL=/var/spool/mail/ardrigh
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/ardrigh/.local/bin:/home/ardrigh/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/ardrigh
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1453
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:HOME=/home/ardrigh
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=ardrigh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-JjRgZIrg7K,guid=f022a8a2c0e5e3bb7c60fbcb00000054
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/ardrigh
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-ardrigh-V6RZ1W/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1459,unix/unix:/tmp/.ICE-unix/1459
:SSH_AUTH_SOCK=/tmp/keyring-L3A7Hp/ssh
:GPG_AGENT_INFO=/tmp/keyring-L3A7Hp/gpg:0:1
:LC_TIME=en_NZ.utf8
:LC_NUMERIC=en_NZ.utf8
:LC_MONETARY=en_NZ.utf8
:LC_MEASUREMENT=en_NZ.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:DESKTOP_STARTUP_ID=gnome-shell-1676-tighnacheo.pro.local-evolution-0_TIME135579
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1910

smolt_data:
:
:
:General
:=================================
:UUID: 3c04be99-cb6c-4bb8-af59-2126db421818
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_GB.utf8
:Platform: x86_64
:BogoMIPS: 4788.06
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2400
:System Memory: 5832
:System Swap: 9213
:Vendor: Acer
:System: Aspire 5740 Rev
:Form factor: Notebook
:Kernel: 3.2.8-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:4133:830) pci, None, HOST/PCI, Core Processor DRAM Controller
:(32902:69:4133:830) pci, pcieport, PCI/PCI, Core Processor PCI Express x16 Root Port
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:4133:830) pci, None, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15145:4133:830) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15113:4133:830) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4133:830) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(4098:26817:4133:830) pci, radeon, VIDEO, Madison [AMD Radeon HD 5000M Series]
:(4098:43616:4133:830) pci, snd_hda_intel, MULTIMEDIA, Redwood HDMI Audio [Radeon HD 5600 Series]
:(32902:15164:4133:830) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:9288:4133:830) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15204:4133:830) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(5348:5778:4133:829) pci, tg3, ETHERNET, Aspire 7740G
:(32902:15170:4133:830) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4133:830) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15190:4133:830) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15156:4133:830) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(5772:42:4187:57375) pci, ath9k, NETWORK, AR928X Wireless Network Adapter (PCI-Express)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-df10fc7a-f178-485e-82aa-d8959d75558a / ext4 4096 4096 3918159 2722545 2525963 983040 803031 803031
:/dev/sda2 /boot ext4 1024 1024 508745 412519 386919 128016 127785 127785
:/dev/mapper/luks-7afa9fa7-5285-4c7f-8a37-27820925d3ef /var ext4 4096 4096 26174432 24770617 23459923 6553600 6488313 6488313
:/dev/mapper/luks-4fe01385-2dea-4801-975d-eb339f9d7fe9 /home ext4 4096 4096 123509347 45243524 39061457 30916608 30871925 30871925
:

var_log_messages:
:Feb 27 12:40:23 tighnacheo kernel: [  158.942172] evolution[2023] general protection ip:3b8887e9c2 sp:7fd81e1ecbc0 error:0 in libc-2.14.90.so[3b88800000+1ad000]
:Feb 27 12:40:25 tighnacheo abrt[2027]: Saved core dump of pid 1910 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-02-27-12:40:23-1910 (296923136 bytes)

xsession_errors:
:  mv /home/ardrigh/.evolution/cache/http /home/ardrigh/.cache/evolution/http
:  rmdir /home/ardrigh/.evolution/cache
:  rmdir /home/ardrigh/.evolution/addressbook
:  rmdir /home/ardrigh/.evolution/calendar
:  rmdir /home/ardrigh/.evolution/cache
:  rmdir /home/ardrigh/.evolution/memos
Comment 1 Dagan McGregor 2012-03-09 02:26:10 EST
Created attachment 568832 [details]
File: gconf_subtree
Comment 2 Dagan McGregor 2012-03-09 02:26:12 EST
Created attachment 568833 [details]
File: build_ids
Comment 3 Dagan McGregor 2012-03-09 02:26:15 EST
Created attachment 568834 [details]
File: dso_list
Comment 4 Dagan McGregor 2012-03-09 02:26:17 EST
Created attachment 568835 [details]
File: maps
Comment 5 Dagan McGregor 2012-03-09 02:26:19 EST
Created attachment 568836 [details]
File: backtrace
Comment 6 Milan Crha 2012-03-09 03:42:47 EST
Thanks for a bug report. I checked the backtrace, but I do not see much from the crashing thread, it seems it crashed on thread finalization:

Thread 1 (Thread 0x7fd81e1ed700 (LWP 2023)):
#0  _int_free (av=0x7fd7e8000020, p=0x7fd7e8001440, have_lock=0) at malloc.c:4066
#1  0x0000003b8895d7ec in __res_iclose (statp=0x7fd81e1eddb8, free_addr=<optimized out>) at res_init.c:619
#2  res_thread_freeres () at res_init.c:646
#3  res_thread_freeres () at res_init.c:640
#4  0x0000003b8895d732 in __libc_thread_freeres () at thread-freeres.c:30
#5  0x0000003b88c07da3 in start_thread (arg=0x7fd81e1ed700) at pthread_create.c:319
#6  0x0000003b888f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

which suggests that this is some kind of memory corruption. The other thing I can see from the backtrace is that there are quite many running imapx_parser_thread-s and imapx_idle_thread-s, which is rather unusual. One of the threads is also reconnecting to your mail server. I cannot tell much from any of these.

Was there any kind of broken connection to the internet, or you server got offline unexpectedly, thus the imapx mail account was forced to reconnect?
Maybe it's related to the issue. Also, did this happen only once, or you are able to reproduce this with certain steps? I'm asking, because memory corruption can be sometimes caught by valgrind.
Comment 7 Dagan McGregor 2012-03-09 05:01:10 EST
 I believe you are right, I think this crash did happen about the same time as my wireless stopped working (ath9k known bug), and I believe Evolution was in the process of checking or loading email when it crashed.

 I haven't had this happen a second time yet, but thought it was worth reporting anyway, as I have had Evolution freak out a number of times, and it would be good if it handled these scenarios without crashing.

 I have 3 imapx accounts configured, all of them have mail sitting in them, one that holds my archive has a few thousand emails. The accounts all work normally, in this instance though I think it was a combination of a high number of emails and the wireless being killed.
Comment 8 Milan Crha 2012-03-12 06:24:52 EDT
Thanks for the update. I think we can close this in favour of an upstream
bug [1], which is about issues when unexpected disconnect & connect happens. There is also a bug #706413 from evolution 3.0.1, which describes just this, also with imapx being involved.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=650685

Note You need to log in before you can comment on or make changes to this bug.