Bug 801739 - Regression with /i, latin1 chars
Regression with /i, latin1 chars
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://rt.perl.org/rt3/Public/Bug/Di...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 05:24 EST by Petr Pisar
Modified: 2012-12-20 11:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 801751 (view as bug list)
Environment:
Last Closed: 2012-12-20 11:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-03-09 05:24:11 EST
$ perl -e 'use 5.012; my $x="br\x{f8}ndby"; $x =~ s/b/X/gi; say $x;'
Xr�ndby

This is regression introduced in Perl 5.14. perl-5.14.2-197.fc16.x86_64 is affected.

Reported to upstream <https://rt.perl.org/rt3/Public/Bug/Display.html?id=101710> a and fixed in development tree by commit:

commit bbdd8bad57f8d77a4e6c3725a49d4d3589efedd7
Author: Karl Williamson <public@khwilliamson.com>
Date:   Tue Nov 1 17:57:15 2011 -0600

    PATCH: [perl #101710] Regression with /i, latin1 chars.
    
    The root cause of this bug is that it was assuming that a string was in
    utf8 when it wasn't, and so was thinking that a byte was a starter byte
    that wasn't, so was skipping ahead based on that starter byte.
Comment 1 Petr Pisar 2012-09-11 04:12:22 EDT
perl-5.14.2-213.fc17.x86_64 affected too. perl 5.16 (F≥18) is Ok.
Comment 2 Fedora Update System 2012-09-11 12:53:40 EDT
perl-5.14.2-214.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-5.14.2-214.fc17
Comment 3 Fedora Update System 2012-09-11 13:03:16 EDT
perl-5.14.2-200.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-5.14.2-200.fc16
Comment 4 Fedora Update System 2012-09-11 20:27:04 EDT
Package perl-5.14.2-214.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-5.14.2-214.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13829/perl-5.14.2-214.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-14 08:17:27 EDT
perl-5.14.2-215.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-5.14.2-215.fc17
Comment 6 Fedora Update System 2012-09-14 08:18:45 EDT
perl-5.14.2-201.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-5.14.2-201.fc16
Comment 7 Fedora Update System 2012-12-20 11:18:50 EST
perl-5.14.2-214.fc17 has been pushed to the Fedora 17 obsolete repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.