Bug 801771 - rpm: error: unpacking of archive failed on file ...: cpio: open
rpm: error: unpacking of archive failed on file ...: cpio: open
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 08:16 EST by Rex Dieter
Modified: 2012-03-12 10:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 10:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-03-09 08:16:10 EST
Not sure if these is really rpm's fault or not, but... :)

some bad'ish things happened during a routine 'yum update' this morning, several packages failed to install/update:
error: unpacking of archive failed on file ...: cpio: open

$ sudo yum update
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dracut.noarch 0:017-22.git20120302.fc17 will be updated
---> Package dracut.noarch 0:017-40.git20120308.fc17 will be an update
---> Package kde-runtime.x86_64 0:4.8.1-1.fc17 will be updated
---> Package kde-runtime.x86_64 0:4.8.1-2.fc17 will be an update
---> Package kde-runtime-libs.x86_64 0:4.8.1-1.fc17 will be updated
---> Package kde-runtime-libs.x86_64 0:4.8.1-2.fc17 will be an update
---> Package kde-workspace.x86_64 0:4.8.1-1.fc17 will be updated
---> Package kde-workspace.x86_64 0:4.8.1-2.fc17 will be an update
---> Package kde-workspace-libs.x86_64 0:4.8.1-1.fc17 will be updated
---> Package kde-workspace-libs.x86_64 0:4.8.1-2.fc17 will be an update
---> Package polkit.x86_64 0:0.104-5.fc17 will be updated
---> Package polkit.x86_64 0:0.104-6.fc17 will be an update
---> Package xorg-x11-xinit.x86_64 0:1.3.1-3.fc17 will be updated
---> Package xorg-x11-xinit.x86_64 0:1.3.1-5.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================================
 Package                                  Arch                         Version                                       Repository                             Size
=================================================================================================================================================================
Updating:
 dracut                                   noarch                       017-40.git20120308.fc17                       updates-testing                       181 k
 kde-runtime                              x86_64                       4.8.1-2.fc17                                  kde-testing                           5.8 M
 kde-runtime-libs                         x86_64                       4.8.1-2.fc17                                  kde-testing                           1.2 M
 kde-workspace                            x86_64                       4.8.1-2.fc17                                  kde-testing                           9.3 M
 kde-workspace-libs                       x86_64                       4.8.1-2.fc17                                  kde-testing                           944 k
 polkit                                   x86_64                       0.104-6.fc17                                  updates-testing                       136 k
 xorg-x11-xinit                           x86_64                       1.3.1-5.fc17                                  updates-testing                        51 k

Transaction Summary
=================================================================================================================================================================
Upgrade  7 Packages

Total download size: 18 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
(1/7): dracut-017-40.git20120308.fc17.noarch.rpm                                                                                          | 181 kB     00:00     
(2/7): kde-runtime-4.8.1-2.fc17.x86_64.rpm                                                                                                | 5.8 MB     00:11     
(3/7): kde-runtime-libs-4.8.1-2.fc17.x86_64.rpm                                                                                           | 1.2 MB     00:02     
(4/7): kde-workspace-4.8.1-2.fc17.x86_64.rpm                                                                                              | 9.3 MB     00:18     
(5/7): kde-workspace-libs-4.8.1-2.fc17.x86_64.rpm                                                                                         | 944 kB     00:01     
(6/7): polkit-0.104-6.fc17.x86_64.rpm                                                                                                     | 136 kB     00:00     
(7/7): xorg-x11-xinit-1.3.1-5.fc17.x86_64.rpm                                                                                             |  51 kB     00:00     
-----------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                            501 kB/s |  18 MB     00:36     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : kde-runtime-libs-4.8.1-2.fc17.x86_64                                                                                                         1/14 
Error unpacking rpm package kde-runtime-libs-4.8.1-2.fc17.x86_64
error: unpacking of archive failed on file /usr/lib64/kde4/kio_nepomuk.so;4f5a01a8: cpio: open
  Updating   : kde-runtime-4.8.1-2.fc17.x86_64                                                                                                              2/14 
error: kde-runtime-libs-4.8.1-2.fc17.x86_64: install failed
  Updating   : kde-workspace-libs-4.8.1-2.fc17.x86_64                                                                                                       3/14 
/sbin/ldconfig: file /lib64/libknotifyconfig.so.4 is truncated

/sbin/ldconfig: file /lib64/libknotifyconfig.so.4.8.0 is truncated

/sbin/ldconfig: /lib64/libpgf.so.4.1.6 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /lib64/libpgf.so.4 is not an ELF file - it has the wrong magic bytes at the start.

  Updating   : kde-workspace-4.8.1-2.fc17.x86_64                                                                                                            4/14 
  Updating   : polkit-0.104-6.fc17.x86_64                                                                                                                   5/14 
/sbin/ldconfig: file /lib64/libknotifyconfig.so.4 is truncated

/sbin/ldconfig: file /lib64/libknotifyconfig.so.4.8.0 is truncated

/sbin/ldconfig: /lib64/libpgf.so.4.1.6 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /lib64/libpgf.so.4 is not an ELF file - it has the wrong magic bytes at the start.

  Updating   : xorg-x11-xinit-1.3.1-5.fc17.x86_64                                                                                                           6/14 
  Updating   : dracut-017-40.git20120308.fc17.noarch                                                                                                        7/14 
  Cleanup    : dracut-017-22.git20120302.fc17.noarch                                                                                                        8/14 
  Cleanup    : kde-workspace-libs-4.8.1-1.fc17.x86_64                                                                                                       9/14 
  Cleanup    : kde-workspace-4.8.1-1.fc17.x86_64                                                                                                           10/14 
/sbin/ldconfig: file /lib64/libknotifyconfig.so.4 is truncated

/sbin/ldconfig: file /lib64/libknotifyconfig.so.4.8.0 is truncated

/sbin/ldconfig: /lib64/libpgf.so.4.1.6 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /lib64/libpgf.so.4 is not an ELF file - it has the wrong magic bytes at the start.

  Cleanup    : kde-runtime-4.8.1-1.fc17.x86_64                                                                                                             11/14 
error: kde-runtime-libs-4.8.1-1.fc17.x86_64: erase skipped
  Cleanup    : polkit-0.104-5.fc17.x86_64                                                                                                                  12/14 
  Cleanup    : xorg-x11-xinit-1.3.1-3.fc17.x86_64                                                                                                          13/14 
/sbin/ldconfig: file /lib64/libknotifyconfig.so.4 is truncated

/sbin/ldconfig: file /lib64/libknotifyconfig.so.4.8.0 is truncated

/sbin/ldconfig: /lib64/libpgf.so.4.1.6 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /lib64/libpgf.so.4 is not an ELF file - it has the wrong magic bytes at the start.

  Verifying  : kde-workspace-4.8.1-2.fc17.x86_64                                                                                                            1/14 
  Verifying  : kde-workspace-libs-4.8.1-2.fc17.x86_64                                                                                                       2/14 
  Verifying  : dracut-017-40.git20120308.fc17.noarch                                                                                                        3/14 
  Verifying  : kde-runtime-4.8.1-2.fc17.x86_64                                                                                                              4/14 
  Verifying  : xorg-x11-xinit-1.3.1-5.fc17.x86_64                                                                                                           5/14 
  Verifying  : polkit-0.104-6.fc17.x86_64                                                                                                                   6/14 
  Verifying  : xorg-x11-xinit-1.3.1-3.fc17.x86_64                                                                                                           7/14 
  Verifying  : dracut-017-22.git20120302.fc17.noarch                                                                                                        8/14 
  Verifying  : kde-workspace-4.8.1-1.fc17.x86_64                                                                                                            9/14 
  Verifying  : kde-workspace-libs-4.8.1-1.fc17.x86_64                                                                                                      10/14 
kde-runtime-libs-4.8.1-1.fc17.x86_64 was supposed to be removed but is not!
  Verifying  : kde-runtime-libs-4.8.1-1.fc17.x86_64                                                                                                        11/14 
  Verifying  : kde-runtime-4.8.1-1.fc17.x86_64                                                                                                             12/14 
  Verifying  : polkit-0.104-5.fc17.x86_64                                                                                                                  13/14 
  Verifying  : kde-runtime-libs-4.8.1-2.fc17.x86_64                                                                                                        14/14 

Updated:
  dracut.noarch 0:017-40.git20120308.fc17  kde-runtime.x86_64 0:4.8.1-2.fc17     kde-workspace.x86_64 0:4.8.1-2.fc17  kde-workspace-libs.x86_64 0:4.8.1-2.fc17 
  polkit.x86_64 0:0.104-6.fc17             xorg-x11-xinit.x86_64 0:1.3.1-5.fc17 

Failed:
  kde-runtime-libs.x86_64 0:4.8.1-1.fc17                                          kde-runtime-libs.x86_64 0:4.8.1-2.fc17                                         

Complete!
Comment 1 Panu Matilainen 2012-03-12 05:45:32 EDT
Mm, that doesn't look very healthy :)

If you can reproduce it, 'rpm -Uvvh --fsmdebug' on kde-runtime-libs package might shed a bit more light on what's going on.
Comment 2 Rex Dieter 2012-03-12 10:49:41 EDT
After trying all sorts of things, looks like this box simply had hopeless filesystem corruption, possibly due to my messing with trying to get hibernate working here.

Anyway, ended up with an unbootable system ultimately and re-installed.  so, I've no inclination or evidence that this was rpm's fault at all.

Note You need to log in before you can comment on or make changes to this bug.