Bug 801780 - While bootstrap PRM functions - returns warning - scriptlet failure (beta 3)
While bootstrap PRM functions - returns warning - scriptlet failure (beta 3)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.1
Unspecified Linux
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 08:43 EST by Steve Reichard
Modified: 2014-01-27 08:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Reichard 2012-03-09 08:43:23 EST
Description of problem:


rpm -ivh http://cf-se3.cloud.lab.eng.bos.redhat.com/pub/candlepin-cert-consumer-cf-se3.cloud.lab.eng.bos.redhat.com-1.0-1.noarch.rpm
Retrieving http://cf-se3.cloud.lab.eng.bos.redhat.com/pub/candlepin-cert-consumer-cf-se3.cloud.lab.eng.bos.redhat.com-1.0-1.noarch.rpm
Preparing...                ##################################################
candlepin-cert-consumer-cf-s##################################################
warning: %post(candlepin-cert-consumer-cf-se3.cloud.lab.eng.bos.redhat.com-1.0-1.noarch) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):


[root@cf-se3 content]# /pub/scripts/post_install_configuration_scripts/cf-se-versions 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-se3.cloud.lab.eng.bos.redhat.com 2.6.32-220.4.2.el6.x86_64 #1 SMP Mon Feb 6 16:39:28 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
PyYAML-3.09-14.el6_1.x86_64
facter-1.5.9-1.el6.noarch
js-1.8.5-6.el6.x86_64
mongodb-1.8.2-3.el6.x86_64
mongodb-server-1.8.2-3.el6.x86_64
puppet-2.6.11-1.el6_1.noarch
pymongo-1.9-8.el6_1.x86_64
tomcat6-6.0.24-35.el6_1.noarch
ruby-1.8.7.352-6.el6.x86_64
grinder-0.0.139-1.el6.noarch
postgresql-server-8.4.9-1.el6_1.1.x86_64
postgresql-8.4.9-1.el6_1.1.x86_64
candlepin-0.5.23-1.el6.noarch
pulp-1.0.0-4.el6.noarch
katello-0.1.301-2.el6.noarch
katello-all-0.1.301-2.el6.noarch
katello-cli-0.1.100-2.el6.noarch
katello-configure-0.1.101-1.el6.noarch
[root@cf-se3 content]# 





How reproducible:

each time I've tried

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike McCune 2012-03-21 10:30:59 EDT
I retested with Beta5 and Beta6 and this error no longer occurs.  It was fixed in this commit:

commit 88daa3037436364f587d8a7fcbd6254e540a78a3
Author: Lukas Zapletal <lzap+git@redhat.com>
Date:   Fri Mar 2 15:50:19 2012 +0100

    790835 - fixing deployment url and goferd restart in bootstrap

in upstream
Comment 2 James Laska 2012-03-21 14:54:50 EDT
Requesting blocker, this package needs to install cleanly.  I haven't exhaustively examined what exactly is failing with the scriptlet.
Comment 3 Jeff Weiss 2012-03-22 14:21:49 EDT
This is working for me, haven't had any trouble installing the client bootstrap rpm.  Verified, katello-0.1.304-1.el6.noarch
Comment 4 James Laska 2012-03-22 15:36:48 EDT
(In reply to comment #3)
> This is working for me, haven't had any trouble installing the client bootstrap
> rpm.  Verified, katello-0.1.304-1.el6.noarch

I've had no problems installing it, but it would emit the %script failures during install.  Is that problem also gone?  

/me will get to retesting after verifying some pulp stuff
Comment 6 Mike McCune 2013-08-16 14:02:03 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.