Bug 801804 - perl SRPM claims wrong version of Compress::Raw::Zlib
perl SRPM claims wrong version of Compress::Raw::Zlib
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: perl-maint-list
Lukas Zachar
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 09:50 EST by Chris Adams
Modified: 2016-01-13 04:10 EST (History)
5 users (show)

See Also:
Fixed In Version: perl-5.10.1-124.el6
Doc Type: Bug Fix
Doc Text:
Cause Comparing perl-Compress-Raw-Zlib package version and Compress::Raw::Zlib::VERSION variable provided by the Perl module. Consequence The two version misalign. RPM package claims higher version. Fix RPM package version has been changed to 2.020 to align with source code. Epoch number of the package has been increased to preserve RPM package version string ordering. Result The perl-Compress-Raw-Zlib version is in line with contained Perl Compress::Raw::Zlib now.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:47:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2012-03-09 09:50:10 EST
The perl source RPM specfile has:

%define                     Compress_Raw_Zlib_version 2.023

However, the actual version is only 2.020 (see ext/Compress-Raw-Zlib/lib/Compress/Raw/Zlib.pm).  This means that RHEL 6 includes an RPM called perl-Compress-Raw-Zlib-2.023-119.el6_1.1.x86_64.rpm, but it provides "perl(Compress::Raw::Zlib) = 2.020".  This is broken and highly confusing.
Comment 2 Marcela Mašláňová 2012-03-09 10:16:55 EST
You are right. It is very unfortunate. Thank you for you report.
Comment 4 RHEL Product and Program Management 2012-03-09 10:29:34 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 6 Petr Pisar 2012-03-12 06:20:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Comparing perl-Compress-Raw-Zlib package version and
    Compress::Raw::Zlib::VERSION variable provided by the
    Perl module.
Consequence
    The two version misalign. RPM package claims higher
    version.
Fix
    RPM package version has been changed to 2.020 to align
    with source code. Epoch number of the package has been
    increased to preserve RPM package version string
    ordering.
Result
    The perl-Compress-Raw-Zlib version is in line with
    contained Perl Compress::Raw::Zlib now.
Comment 10 errata-xmlrpc 2012-06-20 09:47:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0843.html

Note You need to log in before you can comment on or make changes to this bug.