Bug 801818 - [abrt] kde-runtime-4.8.1-1.fc17: lockInline: Process /usr/bin/nepomukservicestub was killed by signal 11 (SIGSEGV)
[abrt] kde-runtime-4.8.1-1.fc17: lockInline: Process /usr/bin/nepomukservices...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-runtime (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:42a2f2bd89e1626ecc41fcd563d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 10:11 EST by admin
Modified: 2012-04-25 07:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-10 08:50:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (7.84 KB, text/plain)
2012-03-09 10:11 EST, admin
no flags Details
File: pwd (33 bytes, text/plain)
2012-03-09 10:11 EST, admin
no flags Details
File: backtrace (22.37 KB, text/plain)
2012-03-09 10:11 EST, admin
no flags Details
File: smolt_data (2.79 KB, text/plain)
2012-03-09 10:11 EST, admin
no flags Details
File: coredump (12.82 MB, text/plain)
2012-03-09 10:16 EST, admin
no flags Details
File: xsession_errors (1.49 KB, text/plain)
2012-03-09 10:16 EST, admin
no flags Details
File: maps (39.47 KB, text/plain)
2012-03-09 10:16 EST, admin
no flags Details
File: dso_list (8.10 KB, text/plain)
2012-03-09 10:16 EST, admin
no flags Details

  None (edit)
Description admin 2012-03-09 10:11:23 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/nepomukservicestub nepomukqueryservice
comment:        When I'm using kontact (reading mail) - this happen. After this I can't check the mail without rebooting my laptop.
crash_function: lockInline
executable:     /usr/bin/nepomukservicestub
kernel:         3.3.0-0.rc6.git0.2.fc17.x86_64
pid:            1750
reason:         Process /usr/bin/nepomukservicestub was killed by signal 11 (SIGSEGV)
time:           Пт. 09 марта 2012 21:51:02
uid:            1000
username:       raistlin

backtrace:      Text file, 22905 bytes
dso_list:       Text file, 8290 bytes
event_log:      Binary file, 8026 bytes
maps:           Text file, 40421 bytes
pwd:            Binary file, 33 bytes
smolt_data:     Binary file, 2857 bytes
xsession_errors: Binary file, 1523 bytes

build_ids:
:7fb69ca76eec72ea4c3a36939e73213074f80a71
:63651cdc0224824a9c9324c77c3b5887378e871d
:f4f9ce91c43285df84177f9684a3e7f190a0aae1
:ae1f34abaca7b7ae310a9743c310cfacc38ada5a
:09dfa113518eba4af80229524e49420efdd706e7
:5b712ca830d19bae12a987fe9a0010277792d28a
:3dd28f8a8b722d6f4d332bc688cc6b8a93f1cf16
:247132297f287226a24c12e683292f5c94013066
:e850c9c2577f79b97ad4c53dbf9b0964682dcbaa
:b1e3a6defd2119a017e2c5b43fbaf7d48d46a9cd
:de7dfd6b80aed35c1ecace885cc7f963030d5c82
:f46d1ce707b94539b90e5be9841948f9e9c85595
:2348d82efc78d838cb28f784c3a61c627d45278a
:3d9a940472c381889737bb262ab0ab1b04b73411
:66ff6e23f48b16dd1cd292e31a109a8c98ff70f2
:8a58512c2cc89530f70932553442289158de3083
:cc1ca3c37569498ad89d12b401b29aea862e1207
:a4c506f4136678e734dae9bc29c9bafeedff1343
:6f7bc504bdc4c06cd2f6de3768abcafb3c6efb6f
:2c09a3f87a92231b0acabb79968d235d61c36967
:43ff5c6ac32fdbb249c0738b601d80522e7ff9c8
:16a77763acec4bd96c7e8ebb19afe51a8ec5a2de
:dd21f08880cf87ac1242266eb1dd7de0c26265ce
:59ab499ab7c3e141c28685d3226d09e2ffaf76a9
:9c416df34aef78b429bb43617c68f6d76c29ec6b
:b8469d1c4799f0d9fbbc0be8ca640ed71c585398
:e91010b497ec024178c36f4365b21f668bada0ca
:178b18aae233c755702d3a3bbcd90f8eaf8289ec
:66152dd675d888043d28b36bdcdeb8f2b3f0d391
:6947e315f0765bf884ecc222d91945a1e2ed8767
:1d4df97fa6024b097b634a272447243c95c26d85
:3e9f65a1ee01419219fb006790eb394dab35d0b7
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:725504f07604278fd8fff0abd24c7d5bee49b5ec
:a93c8e8ea99564e904ef3589f4f669f562872eb8
:4a8f467be9ccaa209b756b4ca29fea83fffa832f
:344356c1a518d582f1ce93cd5fbebd16b15306f1
:7c35310fc506498c612d5d982ab03becc4b4817c
:d23ad34ab62b74ab51eb61de167b89aac5fcdc34
:116ae11be891bcddc048fddee29239248ed5d47e
:6e5485e938db64c2939eebbc9a4ec85dcdce1bc8
:9ac3709786a6bf1eda9c2b5bfa9226c6d32cd340
:1105191f3daac14fc9bacffbeec80f82e6923d15
:2ee2cde50be866ba369f8d72e087de876bba9457
:00d6e8a5d861940c0a1e47bae30bc1972f576705
:4f9a85443f33acbad2eb0068b0d8128b38944b9f
:5700354e05ad144ddb4ea0c243bd50fc199e612d
:1adc477dc89b30da9caf7e36f75db53f58d4ef56
:b5797b67e070ac4ccaff8d7180cf635fa0f31cbf
:53a929d2cce1a5b0076dc5dd3c7ef6478c982723
:822e9b3523e8312240f41a25722d539bc77ed436
:d63bb33cc72fe9b843091836ce4cd9526e438480
:652697d945b4084f8ecf3bbd2eeb5d33b69aff4f
:5f30706c1a4415d431f4b778a5f4cc6e0bb0bd0e
:5bc2d347a293d92e3c373d09875abb8a267a9fc4
:c22f6dbb56084ab59991abf9cb2f6eccb14ec823
:d49a449e639c433b2b645a79aa9b82488a221841
:58a5a26936f146d8a5d08f99eba114d2d747dea5
:dc97f77dc1397ce4190c83988e15fe8b6d86e30a
:89071323dc419820c49b8c25c7cfd972c2d949f6
:390ea489840a98849b7ba0dd2fc4279c7889e2c1
:3d29e38241615a73204404cd372572bbfa529dfe
:8e8dbeeb0bf8f6cd406aa09cff8f54808a1566d2
:a095f564bf20c90a6e26a32fe83d4d04c5eadbcb
:666abf228c966f37766ad17cd64ba794136e9ac9
:d804f8ee47797da9213a92f00cd095ecada8d79f
:e7b45476a7aade9754afe29a2dd976eea9d238a6
:45f039e5502bbe765a1f13d93b1fc95250ba6530
:d00535f0a37afea5e676a0c4bcb84a11544852e3
:1fa4aa0f57b72034546fd97a1e0520e7d6502e0d
:277d74794a8d683ef066f298ec72b16b3a5ea5b2
:da81f3e7a7673a368e193aa26e7e2ba6975ce084
:348363b75ba2150fca6a94fb3331dfc75a4f026b
:c4789957ce691318be2a880d9327ecbe222c00ad
:6dba265d8a1d54ccec97164b33d20945761f56b4
:4b044fe80e4c1b69986abc4b160c303048005d4e
:f0264e76a3f8ec444874b1a23d68c2ecaeba5e1c
:33e8bcc0c4773008f11b34ee1e021b6bfe06f97d
:3a3a9c770d587687a75f5471440d976851c516e8
:d74c5facc600e702f7e69f50ecea66c97b2bed77
:3aa364e64dd370c14adc27be6df2d70960406d7e
:580aa7a231ffd80bcc241f995bf73327d233e6bf
:5e4d3691a8a65ad74b4e96e047c55891a735a147
:46fe2763c4865dc6cd3b28818e63f42f4e3b0139
:c04e591ba5fff2694e134125ec6cf7c28c579cb4

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=1020
:XDG_SESSION_ID=2
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=raistlin.hostace.ru
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=dumb
:XDG_SESSION_COOKIE=cf073c66af50b8f1f334212100000017-1331282838.911554-833583839
:XDM_MANAGED=method=classic
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/raistlin/.gtkrc-2.0:/home/raistlin/.gtkrc-2.0-kde4:/home/raistlin/.kde/share/config/gtkrc-2.0
:GS_LIB=
:GNOME_KEYRING_CONTROL=/tmp/keyring-HmWxSV
:KDE_FULL_SESSION=true
:'IMSETTINGS_MODULE=X compose table'
:USER=raistlin
:XCURSOR_SIZE=0
:SSH_AUTH_SOCK=/tmp/ssh-pxavLVhl1019/agent.1019
:DESKTOP_SESSION=kde-plasma
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/raistlin/.local/bin:/home/raistlin/bin
:MAIL=/var/spool/mail/raistlin
:QT_IM_MODULE=xim
:PWD=/home/raistlin
:XMODIFIERS=@im=none
:KDE_SESSION_UID=1000
:GNOME_KEYRING_PID=868
:LANG=ru_RU.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/raistlin
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=Xeonyx
:LOGNAME=raistlin
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bTtEtvVwoo,guid=1ef500272fefb47b6bbde0d200000066
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/raistlin
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/raistlin/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=xim
:XAUTHORITY=/tmp/kde-raistlin/xauth-1000-_0
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:KDE_MULTIHEAD=false
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1132,unix/unix:/tmp/.ICE-unix/1132
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/raistlin/.gtkrc:/home/raistlin/.kde/share/config/gtkrc

var_log_messages:
:Mar  5 08:15:04 raistlin kernel: [12985.965956] nepomukservices[1135]: segfault at 0 ip           (null) sp 00007fff049a26e8 error 14 in nepomukservicestub[400000+7000]
:Mar  5 08:15:08 raistlin abrt[3769]: Saved core dump of pid 1135 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-08:15:04-1135 (86016 bytes)
:Mar  5 11:26:12 raistlin abrt[2191]: Saved core dump of pid 1054 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-11:26:08-1054 (158629888 bytes)
:Mar  5 14:12:12 raistlin abrt[3869]: Saved core dump of pid 2196 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-14:12:08-2196 (115187712 bytes)
:Mar  5 14:13:33 raistlin abrt[3921]: Saved core dump of pid 3877 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-14:13:29-3877 (115253248 bytes)
:Mar  5 14:17:34 raistlin abrt[3981]: Saved core dump of pid 3932 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-14:17:28-3932 (107094016 bytes)
:Mar  5 14:21:17 raistlin abrt[4259]: Saved core dump of pid 3993 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-14:21:13-3993 (98213888 bytes)
:Mar  5 14:22:39 raistlin abrt[4364]: Saved core dump of pid 4263 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-05-14:22:34-4263 (149762048 bytes)
:Mar  6 13:06:36 raistlin abrt[2243]: Saved core dump of pid 1105 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-06-13:06:32-1105 (141549568 bytes)
:Mar  6 14:16:25 raistlin abrt[2819]: Saved core dump of pid 2246 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-06-14:16:19-2246 (89526272 bytes)
:Mar  7 11:59:08 raistlin abrt[2454]: Saved core dump of pid 1161 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-07-11:59:05-1161 (158380032 bytes)
:Mar  7 12:06:59 raistlin abrt[2635]: Saved core dump of pid 2458 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-07-12:06:57-2458 (89632768 bytes)
:Mar  7 19:29:06 raistlin kernel: [ 9259.593417] nepomukservices[2639]: segfault at 0 ip           (null) sp 00007fff8150e8e8 error 14 in nepomukservicestub[400000+7000]
:Mar  7 19:45:49 raistlin kernel: [  957.008141] nepomukservices[1123]: segfault at 0 ip           (null) sp 00007fff63ee0268 error 14 in nepomukservicestub[400000+7000]
:Mar  8 16:27:24 raistlin kernel: [ 2834.832258] nepomukservices[1086]: segfault at 0 ip           (null) sp 00007fffb123ee68 error 14 in nepomukservicestub (deleted)[400000+7000]
:Mar  8 16:27:24 raistlin abrt[3840]: File '/usr/bin/nepomukservicestub' seems to be deleted
:Mar  9 21:51:04 raistlin abrt[6497]: Saved core dump of pid 1750 (/usr/bin/nepomukservicestub) to /var/spool/abrt/ccpp-2012-03-09-21:51:02-1750 (13443072 bytes)
Comment 1 admin 2012-03-09 10:11:29 EST
Created attachment 568928 [details]
File: event_log
Comment 2 admin 2012-03-09 10:11:33 EST
Created attachment 568929 [details]
File: pwd
Comment 3 admin 2012-03-09 10:11:36 EST
Created attachment 568930 [details]
File: backtrace
Comment 4 admin 2012-03-09 10:11:39 EST
Created attachment 568931 [details]
File: smolt_data
Comment 5 admin 2012-03-09 10:16:29 EST
Created attachment 568933 [details]
File: coredump
Comment 6 admin 2012-03-09 10:16:35 EST
Created attachment 568934 [details]
File: xsession_errors
Comment 7 admin 2012-03-09 10:16:40 EST
Created attachment 568935 [details]
File: maps
Comment 8 admin 2012-03-09 10:16:45 EST
Created attachment 568936 [details]
File: dso_list
Comment 9 admin 2012-03-10 08:50:58 EST
Bug was fixed in kde-runtime 4.8.1-2, All works fine.
Comment 10 Rex Dieter 2012-03-10 08:58:05 EST
the patch/change we included in the -2 build, was a minor cosmetic issue, shouldn't be related this this one at all. but, if the problem no longer occurs, so be it. :)
Comment 11 Stan Trzmiel 2012-04-18 09:38:40 EDT
Still happens on KDE 4.8.2

list of rvelant packages:

kde-runtime-4.8.2-1.fc16.i686
kdepim-4.8.2-1.fc16.i686
kde-workspace-4.8.2-3.fc16.i686
kernel-PAE-3.3.1-5.fc16.i686

Usually it happens whe I try to send email with kmail/kontact. Mail composer window greys out and freezez, any further attempt to send/write as draft new mail fails.
Kontact can't be closed, it's pocess has to be killed manually.
Full reboot is nessesary to restore normal operation.
Comment 12 Edney Matias 2012-04-24 13:58:59 EDT
It happens to me when i reboot my machine. When session starts, then bug!
Comment 13 Rex Dieter 2012-04-25 07:56:13 EDT
Edney, sounds like in your case the nepomuk db may be corrupted.  

You could try to backup/rename/delete anything matching:
~/.kde/share/apps/nepomuk/
~/.kde/share/config/nepomuk*

and restart your session and see if problems persist.

Note You need to log in before you can comment on or make changes to this bug.