Bug 801867 - SELinux is preventing WorkerPool/3633 from using the 'ptrace' accesses on a process.
SELinux is preventing WorkerPool/3633 from using the 'ptrace' accesses on a p...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c1c0aae5b8102794686a7763b25...
:
: 802130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 12:14 EST by Mikhail
Modified: 2012-03-12 04:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 12:49:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-03-09 12:14:17 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc6.git0.2.fc17.i686.PAE
reason:         SELinux is preventing WorkerPool/3633 from using the 'ptrace' accesses on a process.
time:           Fri 09 Mar 2012 11:14:07 PM YEKT

description:
:SELinux is preventing WorkerPool/3633 from using the 'ptrace' accesses on a process.
:
:*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************
:
:If you want to deny_ptrace
:Then you must tell SELinux about this by enabling the 'deny_ptrace'boolean.
:Do
:setsebool -P deny_ptrace 0
:
:*****  Plugin catchall (11.6 confidence) suggests  ***************************
:
:If you believe that 3633 should be allowed ptrace access on processes labeled unconfined_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep WorkerPool/3633 /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Objects                 [ process ]
:Source                        WorkerPool/3633
:Source Path                   WorkerPool/3633
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc6.git0.2.fc17.i686.PAE #1 SMP
:                              Mon Mar 5 17:02:45 UTC 2012 i686 i686
:Alert Count                   27
:First Seen                    Wed 07 Mar 2012 11:26:56 PM YEKT
:Last Seen                     Fri 09 Mar 2012 11:13:51 PM YEKT
:Local ID                      00f41eb5-0194-43e3-86f5-e80af2c20ec2
:
:Raw Audit Messages
:type=AVC msg=audit(1331313231.598:107): avc:  denied  { ptrace } for  pid=1750 comm="WorkerPool/1748" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process
:
:
:Hash: WorkerPool/3633,unconfined_t,unconfined_t,process,ptrace
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-03-09 12:49:08 EST
This is not a bug, and is exactly what we are trying to preven apps ptracing processes.  

What does WorkerPool do?
Comment 2 Miroslav Grepl 2012-03-12 04:10:12 EDT
*** Bug 802130 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.