Bug 801880 - Permanently in tty1 write message: message from syslogd @ p5k af xxxxxxxx ... kernel: [yyyyyyyyy] Disabling IRQ 16
Permanently in tty1 write message: message from syslogd @ p5k af xxxxxxxx ......
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 13:02 EST by Mikhail
Modified: 2012-06-27 17:48 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 17:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-03-09 13:02:14 EST
Description of problem:
Permanently in tty1 write message:
message from syslogd @ p5k af Mar 9 23:11:26 ...
kernel: [37.301404] Disabling IRQ 16

uname -a
Linux p5k 3.3.0-0.rc6.git0.2.fc17.i686.PAE #1 SMP Mon Mar 5 17:02:45 UTC 2012 i686 i686 i386 GNU/Linux


mikhail@p5k:~$ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IB (ICH9) 2 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 8800 GT] (rev a2)
02:00.0 Ethernet controller: Atheros Communications L1 Gigabit Ethernet (rev b0)
03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
05:02.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
05:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)
Comment 1 Mike Eddy 2012-03-10 08:10:18 EST
# after updating from 2.6.42.7-1.fc15.x86_64
#                  to 2.6.42.9-1.fc15.x86_64

# every 2 minutes in /var/log/messages

Mar  9 17:58:13 <hostname> kernel: [  942.281943] Disabling IRQ 16
Mar  9 17:58:13 <hostname> kernel: [  942.290971] Polling IRQ 16
Mar  9 17:58:14 <hostname> kernel: [  943.290154] Reenabling IRQ 16

Mar  9 18:00:05 <hostname> kernel: [ 1053.788840] Disabling IRQ 16
Mar  9 18:00:05 <hostname> kernel: [ 1053.798746] Polling IRQ 16
Mar  9 18:00:06 <hostname> kernel: [ 1054.797931] Reenabling IRQ 16

# ... etc

#  cat /proc/interrupts | grep "^ 16"

 16:    6694966          0          0          0   IO-APIC-fasteoi   pata_via, cx88[0], cx88[0], cx88[0]
Comment 2 Oleg Kochkin 2012-03-11 09:56:17 EDT
After updating from kernel-3.2.9-1.fc16.x86_64 to kernel-3.2.9-2.fc16.x86_64

In /var/log/messages

Mar 11 17:32:05 f16 kernel: [ 7652.034892] Disabling IRQ 16
Mar 11 17:32:05 f16 kernel: [ 7652.044449] Polling IRQ 16
Mar 11 17:32:06 f16 kernel: [ 7653.045234] Reenabling IRQ 16

# cat /proc/interrupts | grep "^ 16"
 16:     809862          0          0          0   IO-APIC-fasteoi   nvidia
Comment 3 Josh Boyer 2012-03-12 15:02:44 EDT
The verbose messages should be gone with the next update.
Comment 4 Josh Boyer 2012-03-15 07:26:38 EDT
Could you try this kernel and see if it functions better for you:

http://koji.fedoraproject.org/koji/buildinfo?buildID=307357
Comment 5 Mikhail 2012-03-15 07:57:13 EDT
What about Fedora 17 users with kernel 3.3.x?
Comment 6 Mike Eddy 2012-03-15 08:26:04 EDT
Josh,

I don't think your patch will help me?

# lspci | grep -i ASM | grep 108
06:00.0 PCI bridge: ASMedia Technology Inc. Device 1080 (rev 01)
Comment 7 Josh Boyer 2012-03-15 09:06:28 EDT
(In reply to comment #5)
> What about Fedora 17 users with kernel 3.3.x?

The patch was committed there.  It just doesn't have a build yet.
Comment 8 Josh Boyer 2012-03-15 09:07:41 EDT
(In reply to comment #6)
> Josh,
> 
> I don't think your patch will help me?
> 
> # lspci | grep -i ASM | grep 108
> 06:00.0 PCI bridge: ASMedia Technology Inc. Device 1080 (rev 01)

It should help.  It should apply a quirk based on the detection of that device, and fall back to polling occasionally.  It shouldn't be verbose as it was before.
Comment 9 Domenico Ferrari 2012-03-17 17:02:20 EDT
Same bug for me. It's on IRQ 23

cat /proc/interrupts

  23:    1818779          0   IO-APIC-fasteoi   eth0

upgrade from 3.2.9-1.fc16.i686 to 3.2.9-2.fc16.i686
Comment 10 Domenico Ferrari 2012-03-17 17:05:47 EDT
lspci
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
02:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 7100 GS] (rev a1)


I've noticed this in /proc/interrupts
  24:     440619          0   IO-APIC-fasteoi   nvidia

Is it related to some nvidia issues? I'm using the proprietary driver from RPM Fusion
Comment 11 Mike Eddy 2012-03-19 08:34:11 EDT
(In reply to comment #8)

>> Josh,
>> 
>> I don't think your patch will help me?
>> 
>> # lspci | grep -i ASM | grep 108
>> 06:00.0 PCI bridge: ASMedia Technology Inc. Device 1080 (rev 01)

>It should help.  It should apply a quirk based on the detection of that device,
>and fall back to polling occasionally.  It shouldn't be verbose as it was
>before.

It is still too verbose in my opinion.  I've been on

# uname -a
Linux <hostname> 2.6.42.9-2.fc15.x86_64 #1 SMP Mon Mar 5 20:55:32 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

for 48 hours

# uptime
 08:08:59 up 2 days, 8 min,  5 users,  load average: 0.00, 0.01, 0.05

and I'm still getting the set of messages 16 times an hour

Mar 19 08:04:41 <hostname> kernel: [172928.191900] Disabling IRQ 16
Mar 19 08:04:41 <hostname> kernel: [172928.201727] Polling IRQ 16
Mar 19 08:04:42 <hostname> kernel: [172929.201911] Reenabling IRQ 16

==========

(In reply to comment #10)

> Is it related to some nvidia issues?

I don't have any nvidia hardware.  In fact I'm using the onboard intel graphics:

# lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

The IRQ that seems to be causing the "problem" is for the only PCI card in the system, an hdtv turner card, the pcHDTV HD-5500

#  cat /proc/interrupts | grep "16:"
 16:   22673292          0          0          0   IO-APIC-fasteoi   pata_via, cx88[0], cx88[0], cx88[0]

# lspci | grep -i video
07:01.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
07:01.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
07:01.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
07:01.4 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)

==========

Do these IRQ messages need to be broadcast at such a high priority?  Their display in every terminal window is annoying.


Message from syslogd@<hostname> at Mar 19 08:24:16 ...
 kernel:[174102.262727] Disabling IRQ 16

Message from syslogd@<hostname> at Mar 19 08:25:26 ...
 kernel:[174171.839632] Disabling IRQ 16

Message from syslogd@<hostname> at Mar 19 08:25:32 ...
 kernel:[174178.274565] Disabling IRQ 16

Message from syslogd@<hostname> at Mar 19 08:26:15 ...
 kernel:[174221.176661] Disabling IRQ 16
Comment 12 Domenico Ferrari 2012-03-19 08:50:14 EDT
I've made an update of my Fedora installation. I didn't noticed any message in the terminal from syslog. Kernel is now  3.2.10.
Comment 13 Josh Boyer 2012-03-19 09:37:18 EDT
You'll need kernel 3.2.10-3 or 2.6.42.10-3 or newer.
Comment 14 Mike Eddy 2012-03-23 14:14:05 EDT
(In reply to comment #13)

> You'll need kernel 3.2.10-3 or 2.6.42.10-3 or newer.

This kernel, 2.6.42.10-3, hasn't shown up in fc15 yet?  

The latest seems to be:

kernel.x86_64   2.6.42.9-2.fc15   @updates
Comment 15 Dave Jones 2012-03-23 14:39:24 EDT
2.6.42.12-1 is in updates-testing. (The newer kernels have probably obsoleted the previous ones before they got to @updates, as f15 kernels are slow to accumulate enough karma)

https://admin.fedoraproject.org/updates/FEDORA-2012-3715/kernel-2.6.42.12-1.fc15
Comment 16 Mike Eddy 2012-03-28 13:01:16 EDT
# uname -a
Linux <hostname> 2.6.42.12-1.fc15.x86_64 #1 SMP Tue Mar 20 16:30:08 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

# uptime
 12:58:19 up 2 days,  4:48,  1 user,  load average: 0.00, 0.01, 0.05

Not a single "Disabling IRQ 16" etc

This one's got karma!!!

Thanks

Note You need to log in before you can comment on or make changes to this bug.