Bug 801898 - Rebuild required to work correctly with perl 5.14.2
Rebuild required to work correctly with perl 5.14.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Devel-Cover (Show other bugs)
16
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On: 720744
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 14:09 EST by Ed Santiago
Modified: 2012-03-14 22:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-Devel-Cover-0.78-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 720744
Environment:
Last Closed: 2012-03-14 22:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Santiago 2012-03-09 14:09:05 EST
+++ This bug was initially created as a clone of Bug #720744 +++

Description of problem:
Any attempt to use perl-Devel-Cover in fully updated Fedora 16, results in a
warning printed

  This version of Devel::Cover was built with Perl version 5.014001.
  It is now being run with Perl version 5.014002.
  Attempting to make adjustments, but you may find that some of your modules do
  not have coverage data collected.  You may need to alter the +-inc, +-ignore
  and +-select options.

Version-Release number of selected component (if applicable):

   perl-5.14.2-195.fc16.x86_64
   perl-Devel-Cover-0.78-2.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:

  $ perl -MDevel::Cover -e ''
Comment 1 Paul Howarth 2012-03-09 17:09:23 EST
This just needs a rebuild in F-16; F-17 and Rawhide are OK as a result of the F-17 mass rebuild.

I can do this.
Comment 2 Fedora Update System 2012-03-09 17:19:23 EST
perl-Devel-Cover-0.78-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Devel-Cover-0.78-3.fc16
Comment 3 Fedora Update System 2012-03-10 16:56:15 EST
Package perl-Devel-Cover-0.78-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Devel-Cover-0.78-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3555/perl-Devel-Cover-0.78-3.fc16
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-14 22:21:38 EDT
perl-Devel-Cover-0.78-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.