Bug 801905 - Must refresh screen for "push all" button to appear
Must refresh screen for "push all" button to appear
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Angus Thomas
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 14:26 EST by Steve Reichard
Modified: 2012-04-17 17:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 17:50:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
movie (8.15 MB, video/ogg)
2012-03-09 14:26 EST, Steve Reichard
no flags Details

  None (edit)
Description Steve Reichard 2012-03-09 14:26:14 EST
Created attachment 568989 [details]
movie

Description of problem:

After uploading system template and starting a build all,  I see the push buttons appear next to each image, However, the "push all" button only appears if I refresh the page.  I waited at least 2 minutes in case the button would appear at a scheduled refresh.

movie attached.



Version-Release number of selected component (if applicable):

[root@cf-cloudforms5 imagefactory]# /pub/scripts/post_install_configuration_scripts/cf-versions 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-cloudforms5.cloud.lab.eng.bos.redhat.com 2.6.32-220.4.2.el6.x86_64 #1 SMP Mon Feb 6 16:39:28 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
postgresql-8.4.9-1.el6_1.1.x86_64
mongodb-1.8.2-3.el6.x86_64
euca2ools-1.3.1-4.el6_0.noarch
ruby-1.8.7.352-6.el6.x86_64
rubygems-1.8.16-1.el6.noarch
deltacloud-core-0.5.0-5.el6.noarch
rubygem-deltacloud-client-0.5.0-2.el6.noarch
package libdeltacloud is not installed
hail-0.8-0.2.gf9c5b967.el6_0.x86_64
puppet-2.6.11-1.el6_1.noarch
aeolus-configure-2.5.0-16.el6.noarch
iwhd-1.2-3.el6.x86_64
imagefactory-1.0.0rc8-1.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
[root@cf-cloudforms5 imagefactory]# 



How reproducible:

easily

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Scott Seago 2012-03-09 14:45:48 EST
Currently the build all/push all buttons aren't included in the content that's refreshed automatically. I'm not sure if this is an oversight or if, by design, the only thing that's refreshed is the content area below.
Comment 2 wes hayutin 2012-04-17 17:50:04 EDT
fixed in 

[root@qeblade30 ~]# rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.3-1.el6.noarch
aeolus-all-0.8.9-1.el6.noarch
aeolus-conductor-doc-0.8.9-1.el6.noarch
aeolus-conductor-daemons-0.8.9-1.el6.noarch
aeolus-conductor-0.8.9-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.