Bug 802021 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file /root/.mozilla/firefox/profiles.ini.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' acc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d5be1a36e97161ca3d62f2dad16...
:
: 1067795 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 05:09 EST by oliver.zemann
Modified: 2016-09-15 10:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-10 22:54:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver.zemann 2012-03-10 05:09:29 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc6.git0.2.fc17.x86_64
reason:         SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file /root/.mozilla/firefox/profiles.ini.
time:           Sat 10 Mar 2012 11:09:17 AM CET

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file /root/.mozilla/firefox/profiles.ini.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed read access on the profiles.ini file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                /root/.mozilla/firefox/profiles.ini [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-10.0.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc6.git0.2.fc17.x86_64 #1
:                              SMP Mon Mar 5 16:54:07 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sat 10 Mar 2012 10:41:45 AM CET
:Last Seen                     Sat 10 Mar 2012 10:41:45 AM CET
:Local ID                      d276738c-0dda-438e-aacb-14b90cd0acc0
:
:Raw Audit Messages
:type=AVC msg=audit(1331372505.468:68): avc:  denied  { read } for  pid=1926 comm="plugin-containe" name="profiles.ini" dev="dm-2" ino=790713 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1331372505.468:68): avc:  denied  { open } for  pid=1926 comm="plugin-containe" name="profiles.ini" dev="dm-2" ino=790713 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1331372505.468:68): arch=x86_64 syscall=open success=yes exit=EFAULT a0=7fe3647c2040 a1=0 a2=18 a3=7fff94cad6a0 items=0 ppid=1490 pid=1926 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,admin_home_t,file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-03-10 06:37:57 EST
Are you running firefox as root? not a good idea.
Comment 2 oliver.zemann 2012-03-10 07:42:06 EST
i know that working as root is not a good idea, but i had to fix my system as X11 segfaulted. Any ideas regarding this bug?
Comment 3 Daniel Walsh 2012-03-10 22:54:59 EST
Yes it is not supported.
Comment 4 Daniel Walsh 2014-02-21 16:03:26 EST
*** Bug 1067795 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.