Bug 802023 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' accesses on the file videostats.sxx.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' a...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e0d7d953a576cf7f0bd20e31267...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 05:20 EST by oliver.zemann
Modified: 2012-03-19 10:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-10 06:39:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver.zemann 2012-03-10 05:20:20 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc6.git0.2.fc17.x86_64
reason:         SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' accesses on the file videostats.sxx.
time:           Sat 10 Mar 2012 11:20:11 AM CET

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' accesses on the file videostats.sxx.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed create access on the videostats.sxx file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                videostats.sxx [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-10.0.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc6.git0.2.fc17.x86_64 #1
:                              SMP Mon Mar 5 16:54:07 UTC 2012 x86_64 x86_64
:Alert Count                   12
:First Seen                    Sat 10 Mar 2012 11:19:57 AM CET
:Last Seen                     Sat 10 Mar 2012 11:19:58 AM CET
:Local ID                      0eb13d31-f545-4178-a177-12aa0fb700f8
:
:Raw Audit Messages
:type=AVC msg=audit(1331374798.427:99): avc:  denied  { create } for  pid=1911 comm="plugin-containe" name="videostats.sxx" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1331374798.427:99): arch=x86_64 syscall=open success=no exit=EACCES a0=7f4870cd2cf8 a1=442 a2=1b6 a3=ffffff00 items=0 ppid=1625 pid=1911 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,user_home_dir_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-03-10 06:39:02 EST
Looks like your homedir is mislabled?

restorecon -R -v /home
Comment 2 oliver.zemann 2012-03-10 11:45:05 EST
this fixes it temporarly, but as soon as i restart, i got this warning/bug again. again again and again. so i guess this is a bug.
Comment 3 Daniel Walsh 2012-03-10 22:56:04 EST
What directory is videostats.sxx  being created in?
Comment 4 oliver.zemann 2012-03-11 03:56:46 EDT
I never had to deal with SELinux, i dont know it. Can you help me how to get that information? I have many such messages, like this one:

--
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from create access on the file jsQueue.sxx.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that plugin-container should be allowed create access on the jsQueue.sxx file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                jsQueue.sxx [ file ]
Source                        plugin-containe
Source Path                   /usr/lib64/xulrunner-2/plugin-container
Port                          <Unknown>
Host                          lucy.local
Source RPM Packages           xulrunner-10.0.1-3.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     lucy.local
Platform                      Linux lucy.local 3.3.0-0.rc6.git0.2.fc17.x86_64 #1
                              SMP Mon Mar 5 16:54:07 UTC 2012 x86_64 x86_64
Alert Count                   189
First Seen                    Sat 10 Mar 2012 11:19:57 AM CET
Last Seen                     Sat 10 Mar 2012 01:37:20 PM CET
Local ID                      0eb13d31-f545-4178-a177-12aa0fb700f8

Raw Audit Messages
type=AVC msg=audit(1331383040.978:596): avc:  denied  { create } for  pid=1911 comm="plugin-containe" name="jsQueue.sxx" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1331383040.978:596): arch=x86_64 syscall=open success=no exit=EACCES a0=7f4870cd2930 a1=442 a2=1b6 a3=1 items=0 ppid=1625 pid=1911 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-containe,mozilla_plugin_t,user_home_dir_t,file,create

audit2allowunable to open /sys/fs/selinux/policy:  Permission denied


audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
--

The tcontext=... line says home_dir_t - and as i'm running firefox as regular user i guess it at least *should* be $HOME.
Comment 5 Miroslav Grepl 2012-03-12 04:28:21 EDT
What are you exactly doing?

Also what does

$ find /home -iname videostats*
Comment 6 oliver.zemann 2012-03-18 05:33:39 EDT
[oli@lucy /]$ find /home -iname videostats*
find: `/home/lost+found': Permission denied
/home/oli/.macromedia/Flash_Player/#SharedObjects/D9BTU5CW/s.ytimg.com/videostats.sol

i was browsing on youtube
Comment 7 Miroslav Grepl 2012-03-19 10:34:45 EDT
You will need to fix labeling in your home dir. Please execute

$ restorecon -R -v /home/oli/.macromedia

Note You need to log in before you can comment on or make changes to this bug.