Bug 802058 - Evolution restore fails on upgrade from F14 to F16
Evolution restore fails on upgrade from F14 to F16
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 10:45 EST by Steevithak
Modified: 2012-03-13 03:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 03:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one of the error messages of F14 to F16 upgrade and evolution backup/restore (389.38 KB, image/png)
2012-03-10 10:45 EST, Steevithak
no flags Details

  None (edit)
Description Steevithak 2012-03-10 10:45:47 EST
Created attachment 569096 [details]
one of the error messages of F14 to F16 upgrade and evolution backup/restore

Description of problem:
I've upgraded from Fedora 14 to Fedora 16. Before the upgrade, I was running the latest Evolution available for F14. I did a backup of mail and settings. Then I wiped the disk and did a fresh install of F16. I installed all available updates and then started evolution. I asked it to restore the backup file created on F14. It appeared to be working then presented a message saying it was going to create a duplicate account as part of a transition from mbox to maildir (which I'm pleased to see, I was sad when evolution dropped maildir, I'm glad it's finally back!). 

Anyway, after it finished and Evolution started up, clicking on any of the folders resulted in a big orange box showing a yield symbol with an exclamation point in it and the message 

"Error while Storing folder "whatever'" 
Error storing 'path/to/whatever/' Summary and folder mismatch even after sync.

Initially, all folders in both both accounts did this. After a few minutes several, but not all, of the folders in the top account started working.

Incidentally, there's no obvious indication of which of the two accounts I am supposed delete after the install - I assume one is the permanent maildir account and the other is the temporary mbox that I'm supposed to delete - but which?? (and why can't the restore process delete the temp account automatically?)

Version-Release number of selected component (if applicable):
3.2.3

How reproducible:
not sure, haven't tried it multiple times yet

Steps to Reproduce:
1. Ask Evolution on F14 to backup some mail
2. Wipe and install F16 + updates
3. Ask Evolution on F16 to restore some mail
  
Actual results:
Every folder gets unexpected error message, with no advice on what it means or how to fix it.

Expected results:
Restore (and mbox to maildir conversion) should be handled automatically and any error should be explained and advice provided on how to correct the problem. 

Additional info:
I'm testing this on my laptop which doesn't have that much mail, the backup file was less than 1GB. I'd like to see this work before I upgrade my primary computer, it has probably 20-30 GB of mail covering a 15 year span. 

I'm attaching a screen capture of one of the errors I'm seeing.
Comment 1 Milan Crha 2012-03-12 06:15:29 EDT
Thanks for a bug report. There seems to happen this [1]. If you follow the steps from the documentation, then you may get it fixed soon. Note you should got to the folder which the actual error message says, which is, in your case, ~/.local/share/evolution/mail/local_mbox. I would delete there all the suggested files plus the folders.db file. These will be recreated the next evolution start.

Note the evolution 3.2.3 contains a fix to prevent this error, but it cannot fix it on its own, thus if the corruption of summary happened during the transition, or is caused by other code changes, then the manual fix is required.

(In reply to comment #0)
> Incidentally, there's no obvious indication of which of the two accounts I am
> supposed delete after the install - I assume one is the permanent maildir
> account and the other is the temporary mbox that I'm supposed to delete - but
> which?? (and why can't the restore process delete the temp account
> automatically?)

You cannot delete On This Computer from evolution, that's the actual internal store, using maildir. Open Edit->Preferences->Mail Accounts, there is a list of accounts you can delete, and the one with name steve@localhost is the backup of your mbox folders from Fedora 14. These are kept there for backup purposes, and evolution doesn't delete them just in case if anything would come wrong during transition from mbox to maildir internal format. The current storage in the filesystem is shown in the error message. Once you know the mails are correctly transferred to maildir account you can delete the steve@localhost account with anything what lefts in your local_mbox folder (note there are two folders on the disk, one is named 'local', the other 'local_mbox'; the 'local' corresponds to 'On This Computer' folders.

Please try the above and let here know if everything worked as expected. Thanks in advance.

[1] http://library.gnome.org/users/evolution/3.2/mail-error-folder-mismatch.html.en
Comment 2 Steevithak 2012-03-12 11:58:28 EDT
Ok, thanks, I deleted everything that didn't look like actual mail files including stuff like folders.db, *.ev-summary, *.ibex.index, etc. That seems to have fixed it. I've also deleted the extra copy of the account. Once I went to edit preferences, it was more apparent which one was mbox format. Thanks for your help!

Good to know a fix is in the works. I'll wait until the fixed version is available before upgrading my primary computer to F16.
Comment 3 Milan Crha 2012-03-13 03:05:21 EDT
Good.

(In reply to comment #2)
> Good to know a fix is in the works. I'll wait until the fixed version is
> available before upgrading my primary computer to F16.

Just to clarify, the F16 contains the fix, which makes sure the corruption will not happen again, but it cannot repair already corrupted data. That's the place where manual file "fixing" applies.

Note You need to log in before you can comment on or make changes to this bug.