Bug 802082 - xcb-util now consists of several upstreams packages
xcb-util now consists of several upstreams packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xcb-util (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 17:52 EST by Göran Uddeborg
Modified: 2012-03-30 14:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 16:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2012-03-10 17:52:14 EST
Description of problem:
I trying to compile a program (mcwm) which uses xcb-util.  In particular, it includes the file xcb_keysyms.h.  In F16 that file is included in xcb-util-devel 0.3.6.

In F17 that header file is no longer part of xcb-util-devel 0.3.8.  It appears the reason is that upstreams has split up xcb-util into several packages in 0.3.8.  In addition to xcb-util there is xcb-util-image, xcb-util-keysyms, xcb-util-renderutil, and xcb-util-wm.  (And obviously, I will need at least xcb-util-keysyms.)

It seems to me it would make sense to package all of these for Fedora.  I'm writing this report on the assumption that the package was simply upgraded without anyone noticing the split.  Or maybe I'm wrong?  Maybe there was a conscious decision to omit the separated packages for some reason?

Version-Release number of selected component (if applicable):
xcb-util-0.3.8-2.fc17.x86_64
Comment 1 Rex Dieter 2012-03-29 16:30:59 EDT
Yep, looks like xcb-util upstream spilt things up starting with 0.3.8, so not strictly a downstream/package bug *here* per-se.  Just means that someone needs to some work to package the new components (like any other new package coming to fedora).
Comment 2 Göran Uddeborg 2012-03-30 14:06:06 EDT
It's certainly not a "bug" really.  I just thought it would be natural for the same packager to handle all of the packages, since they probably should be released together.  But it that's not the plan, then sure, we are waiting for a packager for them.  (I'll consider doing it in a little while, if no one else does it before me.)

Note You need to log in before you can comment on or make changes to this bug.