Bug 802131 - "Disabling IRQ" messages after updating to 3.2.9-2.fc16
"Disabling IRQ" messages after updating to 3.2.9-2.fc16
Status: CLOSED DUPLICATE of bug 800520
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 11:49 EDT by Paulo Fessel
Modified: 2012-03-12 11:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 09:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hardware info of my system. (26.20 KB, text/plain)
2012-03-11 11:49 EDT, Paulo Fessel
no flags Details

  None (edit)
Description Paulo Fessel 2012-03-11 11:49:41 EDT
Created attachment 569186 [details]
Hardware info of my system.

Description of problem: after updating to kernel-3.2.9-2.fc16 from Fedora updates channel, I'm getting "Disabling IRQ" messages both for my NVidia 8600GS and the embedded SBx00 Azalia sound card whenever I activate the screen saver of my system. The messages appear both in the system log and in the KDE notifier. This affects KDE's phonon and sometimes this disables the sound card when I unlock the screen of my desktop. When this happens, I have to run "pulseaudio -k && pulseaudio -D" to reactivate it.

Version-Release number of selected component (if applicable): kernel.x86_64    3.2.9-2.fc16

How reproducible: whenever the screen saver goes active, either automatically (timeout of the KDE screensaver configuration) or manually.

Steps to Reproduce:
1. Update kernel to 3.2.9-2.fc16.
2. Lock screen.
3. After some minutes, when unlocking the screen the "Disabling IRQ" messages appear in the KDE notifier and in the system log (/var/log/messages).
  
Actual results: These messages appear in the system log and in the KDE notifier:

Mar 11 12:28:36 wotan kernel: [11220.290615] Disabling IRQ 24
Mar 11 12:28:36 wotan kernel: [11220.301022] Polling IRQ 24
Mar 11 12:28:36 wotan kernel: [11220.310133] Disabling IRQ 16
Mar 11 12:28:36 wotan kernel: [11220.320044] Polling IRQ 16
Mar 11 12:28:37 wotan kernel: [11220.622067] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Mar 11 12:28:37 wotan kernel: [11221.312055] Reenabling IRQ 24
Mar 11 12:28:37 wotan kernel: [11221.322047] Reenabling IRQ 16

Expected results: no messages (and no IRQ disabling) at all.

Additional info: I'm running my system with the 295.17 release of the proprietary NVidia driver, compiled with the specs of the rpmfusion packages.
Comment 1 Josh Boyer 2012-03-12 09:56:37 EDT
Out of curiosity, does this happen when you don't use the proprietary driver?

*** This bug has been marked as a duplicate of bug 800520 ***
Comment 2 Paulo Fessel 2012-03-12 11:14:03 EDT
I haven't tested it. Anyway, it does happen also with the sound card, and it is driven by the standard Linux driver which is OSS AFAIK.

Note You need to log in before you can comment on or make changes to this bug.