Bug 802155 - Clementine does not load due to missing library
Clementine does not load due to missing library
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: clementine (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 14:14 EDT by Charles Rezk
Modified: 2012-03-11 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-11 22:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Rezk 2012-03-11 14:14:34 EDT
Description of problem:

  Clementine (clementine-1.0.1-2) does not load, due to missing library.


Version-Release number of selected component (if applicable):

  clementine-1.0.1-2.fc16


 
How reproducible:

  easily

Steps to reproduce, with results:

  From terminal, run "clementine".  I get

  clementine: errorwhile loading shared libraries: libGLEW.so.1.5: cannot
  open shared object file: No such file or directory


Additional Information:

  Only libGLEW.so.1.6 is present on my system; 1.6 seems to be the only version 
  of this library shipped with Fedora 16

  The clementine-1.0.1-1.fc16 at www.clementine-player.org works fine.

  Perhaps this 1.0.1-2 was built against the wrong version of libGLEW?
Comment 1 Orcan Ogetbil 2012-03-11 14:39:19 EDT
That is interesting. My copy of clementine-1.0.1-2 links to libGLEW.so.1.6. Fedora 16 switched from libGLEW.so.1.5 to libGLEW.so.1.6 in June 2011, and it is highly unlikely that clementine-1.0.1-2 of last month was built against libGLEW.so.1.5.

Maybe your runtime linker got confused. Did you try running "ldconfig" as root manually?

Anyhow, there is a clementine-1.0.1-3 in the updates-testing repo. You could try that as well? (In general it is not a bad idea to take a look in the updates-testing repo before filing bugs.)

Thanks.
Comment 2 Charles Rezk 2012-03-11 15:24:00 EDT
Orcan, I hadn't tried that.  Let's see ...

Running ldconfig on its own doesn't help.  "ldd /usr/bin/clementine" still shows missing dependency on libGLEW.so.1.5.

There is no "/usr/lib/libGLEW.so.1.5".    I manually added a "libGLEW.so.1.5 -> libGLEW.so.1.6.0" link in /usr/lib, and reran ldconfig.  Now clementine (1.0.1-2) runs ok. 

I haven't tried 1.0.1-3 yet.
Comment 3 Charles Rezk 2012-03-11 22:14:38 EDT
This looks like an error in my setup; it should be closed.
Looking carefully through my installed packages, I discovered there were several FC15 packages around that, for some reason, had not been updated.  I don't know why.  Updating them by hand to F16 versions fixed the problem.  The culprit was probably libprojectM.
Comment 4 Orcan Ogetbil 2012-03-11 22:57:48 EDT
I am glad you found a solution. It would be good, if ever possible, to file a bug against the Fedora component you used to do the F-15->F-16 update that was responsible for the faulty configuration you ended up with, in case you can describe how to reproduce the issue, but I know this is very difficult.

Note You need to log in before you can comment on or make changes to this bug.