Bug 802191 - TM shortcuts 2-n don't work
TM shortcuts 2-n don't work
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.5
Unspecified Linux
unspecified Severity medium
: ---
: 1.6-alpha-1
Assigned To: Alex Eng
Joyce Chang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 21:08 EDT by Hedda Peters
Modified: 2013-03-03 22:19 EST (History)
5 users (show)

See Also:
Fixed In Version: Zanata version 1.6-SNAPSHOT (20120321-1619)
Doc Type: Bug Fix
Doc Text:
Cause The code for the translation memory copy shortcut keys Ctrl+Shift+[1-4] checked for characters rather than key codes. Consequence The numbers on a keyboard number pad were not recognised, and on some keyboard mappings numbers above 2 were not recognised. Fix The code was rewritten to recognise keyboard codes, rather than characters. Result Pressing Ctrl+Shift+[1-4] now copies the translation memory match.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-03-11 21:08:35 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Using the shortcut ctrl-shift-1 to copy the first TM match works.
Using the shortcut ctrl-shift-2 (and above) to copy subsequent TM matches does not work for me. Nothing happens.

Reproducible: Always

Steps to Reproduce:
1. Open editor
2. Open message and wait for several TM matches to appear
3. Press Ctrl-shift-2
Actual Results:  
Nothing happens.

Expected Results:  
Copy TM match #2 to msgstr 

Firefox 9.0.1
Comment 1 Hedda Peters 2012-03-11 21:23:39 EDT
Also I was wondering if there is a reason why using the numbers from the number block on the keyboard wouldn't work?

At the moment pressing Ctrl-Shift-1 (using 1-key from number row above letters) works. Pressing Ctrl-Shift-1 (using 1-key from number block on the right) does not work.

If possible, could I suggest making the numbers from the number block work for this, too. Because: 

- Ctrl-Shift-1 (number row) with only my left hand: too hard
- Ctrl-Shift-1 (number row) with right hand for pressing 1: clumsy
- Ctrl-Shift-1 (number block) with right hand for pressing 1: easy

Hope that made sense
Comment 2 Alex Eng 2012-03-12 19:55:21 EDT
Fixed and merged in both 1.5 and master branch.

See https://github.com/zanata/zanata/commit/35ab9acf7b42380f88d7be3b09d33c796a7e32d0
Comment 3 Joyce Chang 2012-03-27 01:38:09 EDT
verified in Zanata version 1.6-SNAPSHOT (20120327-0000)&
            Zanata version 1.5.1-SNAPSHOT (20120322-1258).
Comment 4 Joshua Wulf 2012-04-20 04:10:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    The code for the translation memory copy shortcut keys Ctrl+Shift+[1-4] checked for characters rather than key codes.
Consequence
    The numbers on a keyboard number pad were not recognised, and on some keyboard mappings numbers above 2 were not recognised.
Fix
    The code was rewritten to recognise keyboard codes, rather than characters.
Result
   Pressing Ctrl+Shift+[1-4] now copies the translation memory match.

Note You need to log in before you can comment on or make changes to this bug.