Bug 802207 - getent netgroup hangs when "use_fully_qualified_names = TRUE" in sssd
getent netgroup hangs when "use_fully_qualified_names = TRUE" in sssd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.3
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 01:28 EDT by Amith
Modified: 2013-05-30 13:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.8.0-16.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amith 2012-03-12 01:28:49 EDT
Description of problem:
The "getent netgroup <some-group>" command hangs, when "use_fully_qualified_names = TRUE" is enabled in sssd.conf.

Version-Release number of selected component (if applicable):
sssd-1.8.0-11.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. To produce the issue, setup sssd.conf as below:

[sssd]
reconnection_retries = 3
config_file_version = 2
sbus_timeout = 30
services = nss, pam
domains = LDAP

[nss]
filter_groups = root
filter_users = root
reconnection_retries = 3

[pam]
reconnection_retries = 3

[domain/LDAP]
id_provider = ldap
auth_provider = ldap
enumerate = TRUE
cache_credentials = TRUE
debug_level = 9
chpass_provider = ldap
ldap_tls_reqcert = hard
ldap_uri = ldap://hubcap.lab.eng.pnq.redhat.com
ldap_search_base = dc=example,dc=com
ldap_tls_cacertdir = /etc/openldap/cacerts/

use_fully_qualified_names = TRUE

ldap_schema = rfc2307
ldap_default_bind_dn = cn=Manager,dc=example,dc=com
ldap_default_authtok = Secret123

2. Start sssd service and run the following step:

[root@sssd-client sssd]# getent netgroup some_group

Actual results:
You will observe that the command hangs. Press Ctrl+C to get the prompt back.

[root@sssd-client sssd]# getent netgroup some_group
^C
  
Expected results:
The command should not hang, and user should get back the command prompt.

Additional info:
Comment 2 Jakub Hrozek 2012-03-12 05:58:17 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1248
Comment 7 Jakub Hrozek 2012-04-03 14:40:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 8 Amith 2012-04-11 06:10:56 EDT
Verified on sssd-1.8.0-22.el6.x86_64. 

The output for the associated beaker automation script is given below:

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Verify BZ release ticket #365 :- getent netgroup hangs when use_fully_qualified_names = TRUE
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Verify BZ release ticket #365
:: [   PASS   ] :: Verify BZ release ticket #365
:: [   PASS   ] :: Verify BZ release ticket #365
:: [   LOG    ] :: Duration: 4s
:: [   LOG    ] :: Assertions: 6 good, 0 bad
:: [   PASS   ] :: RESULT: Verify BZ release ticket #365 :- getent netgroup hangs when use_fully_qualified_names = TRUE
Comment 10 errata-xmlrpc 2012-06-20 07:55:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.