Bug 802241 - system halts at first reboot after installation with specific kickstart file
system halts at first reboot after installation with specific kickstart file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 04:05 EDT by Hongqing Yang
Modified: 2012-05-29 03:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 03:37:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (352 bytes, text/plain)
2012-03-12 04:05 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-03-12 04:05:39 EDT
Created attachment 569295 [details]
kickstart file

Description of problem:

system halts at first reboot after installation with the kickstart file 
in the attachment. 
The kickstart file works well with F16. If the packages are removed from the kickstart file, the system can boot normally.

Version-Release number of selected component (if applicable):
F17- Beta TC1

How reproducible:


Steps to Reproduce:
1. install system with ks file
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2012-03-12 04:06:38 EDT
This is branched from bug 787461
Comment 2 Adam Williamson 2012-03-12 17:52:00 EDT
Please provide a reason why this should be considered a Beta blocker, I don't immediately see that it breaches any criteria.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Hongqing Yang 2012-03-12 22:21:30 EDT
(In reply to comment #2)
> Please provide a reason why this should be considered a Beta blocker, I don't
> immediately see that it breaches any criteria.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

I think it does not meet the F17 Beta Release Criteria article 6
The installer must be able to use all kickstart delivery methods
Comment 4 Adam Williamson 2012-03-12 22:42:29 EDT
That criterion is really to do with anaconda's methods for _reading_ kickstart files. It's breached if, say, you specify ks=somethingsomething and then anaconda either explodes or fails to read the kickstart.

The case where anaconda correctly reads and attempts to process the kickstart, but something about the actual contents of the kickstart causes the installed system not to boot, is really pretty different.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Chris Lumens 2012-03-13 11:44:49 EDT
Please state the exact nature of the problem.  Where does the boot stop?  Attach a screenshot or a log or something.
Comment 6 Adam Williamson 2012-03-16 13:42:17 EDT
Discussed at 2012-03-16 blocker review meeting. We agreed that as this seems to be down to the kickstart file itself - or, likely, the package groups specified in it - it does not meet the blocker criteria.

We suspect the bug here is that the base-x group is not in fact sufficient to produce a successful X startup. Booting to multi-user.target may well work. We will investigate further.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Hongqing Yang 2012-05-29 03:37:25 EDT
This is fixed with the current release F17 GA

Note You need to log in before you can comment on or make changes to this bug.