Bug 802310 - [abrt] Crash under mail_mt_free_activity()
[abrt] Crash under mail_mt_free_activity()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:4ee1cd340007e401e1130c8990c...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 05:48 EDT by Mikhail
Modified: 2012-09-27 00:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 00:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (24.61 KB, text/plain)
2012-03-12 05:48 EDT, Mikhail
no flags Details
File: build_ids (10.25 KB, text/plain)
2012-03-12 05:48 EDT, Mikhail
no flags Details
File: maps (73.06 KB, text/plain)
2012-03-12 05:49 EDT, Mikhail
no flags Details
File: backtrace (41.01 KB, text/plain)
2012-03-12 05:49 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 683349 None None None 2012-09-17 09:32:46 EDT

  None (edit)
Description Mikhail 2012-03-12 05:48:50 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        evolution
crash_function: g_type_check_instance_cast
executable:     /usr/bin/evolution
kernel:         3.3.0-0.rc6.git0.2.fc17.i686.PAE
pid:            23737
pwd:            /home/mikhail
reason:         Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
time:           Пн. 12 марта 2012 10:43:32
uid:            1000
username:       mikhail

backtrace:      Text file, 41992 bytes
build_ids:      Text file, 10496 bytes
dso_list:       Text file, 25201 bytes
maps:           Text file, 74812 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=telecon17l.afbank.ru
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=928ad44a76a7008e0260558b00000016-1331439092.502873-763945421
:GNOME_KEYRING_CONTROL=/tmp/keyring-MVDREZ
:IMSETTINGS_MODULE=none
:USER=mikhail
:USERNAME=mikhail
:MAIL=/var/spool/mail/mikhail
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mikhail/.local/bin:/home/mikhail/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mikhail
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=978
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/mikhail
:SHLVL=1
:LOGNAME=mikhail
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-1DYxVxA9FG,guid=a1705255c2143bf7a15a233a00000021
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mikhail
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-mikhail-Eu0Elw/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/980,unix/unix:/tmp/.ICE-unix/980
:GPG_AGENT_INFO=/tmp/keyring-MVDREZ/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-MVDREZ/ssh
:LC_TIME=ru_RU.utf8
:LC_NUMERIC=ru_RU.utf8
:LC_MONETARY=ru_RU.utf8
:LC_MEASUREMENT=ru_RU.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:G_MESSAGES_DEBUG=all
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=23737
:DESKTOP_STARTUP_ID=gnome-shell-1200-telecon17l.afbank.ru-evolution-35_TIME88309341

var_log_messages:
:Mar 11 10:00:11 telecon17l yum[17205]: Updated: evolution-3.3.91-1.fc17.i686
:Mar 11 10:01:35 telecon17l yum[17205]: Updated: evolution-mapi-3.3.91-1.fc17.i686
:Mar 11 10:01:36 telecon17l yum[17205]: Updated: evolution-NetworkManager-3.3.91-1.fc17.i686
:Mar 11 11:38:03 telecon17l abrt[5728]: Saved core dump of pid 5710 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-11-11:38:02-5710 (67026944 bytes)
:Mar 11 11:44:28 telecon17l yum[5983]: Installed: evolution-data-server-3.3.91-1.fc17.i686
:Mar 11 16:16:07 telecon17l abrt[10176]: Saved core dump of pid 10160 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-11-16:16:06-10160 (66895872 bytes)
:Mar 12 09:54:29 telecon17l kernel: [85409.223154] evolution[12999]: segfault at 8 ip 4323c269 sp bfcca3a0 error 4 in libgobject-2.0.so.0.3120.0[4320a000+4e000]
:Mar 12 09:54:29 telecon17l abrt[22863]: File '/usr/bin/evolution' seems to be deleted
:Mar 12 09:55:05 telecon17l abrt[22863]: Saved core dump of pid 12999 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-12-09:54:29-12999 (399806464 bytes)
:Mar 12 09:56:01 telecon17l kernel: [85501.698153] evolution[22891]: segfault at 3 ip 411892e0 sp bf830290 error 4 in libgdk-3.so.0.318.0[41175000+82000]
:Mar 12 09:56:02 telecon17l abrt[22927]: Saved core dump of pid 22891 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-12-09:56:01-22891 (98623488 bytes)
:Mar 12 09:56:48 telecon17l kernel: [85548.560707] evolution[22951]: segfault at 8 ip 4323c269 sp bfc79480 error 4 in libgobject-2.0.so.0.3120.0[4320a000+4e000]
:Mar 12 09:56:49 telecon17l abrt[22981]: Saved core dump of pid 22951 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-12-09:56:48-22951 (101539840 bytes)
:Mar 12 10:31:04 telecon17l kernel: [87604.998327] evolution[23007]: segfault at 26 ip 00000026 sp bff5a1cc error 14 in evolution[8048000+4000]
:Mar 12 10:31:12 telecon17l abrt[23579]: Saved core dump of pid 23007 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-12-10:31:05-23007 (197021696 bytes)
:Mar 12 10:42:39 telecon17l kernel: [88299.900598] evolution[23591]: segfault at 8 ip 4323c269 sp bfcb60c0 error 4 in libgobject-2.0.so.0.3120.0[4320a000+4e000]
:Mar 12 10:42:43 telecon17l abrt[23725]: Saved core dump of pid 23591 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-12-10:42:40-23591 (118747136 bytes)
:Mar 12 10:43:32 telecon17l kernel: [88352.760589] evolution[23737]: segfault at 8 ip 4323c269 sp bfe69b90 error 4 in libgobject-2.0.so.0.3120.0[4320a000+4e000]
:Mar 12 10:43:34 telecon17l abrt[23777]: Saved core dump of pid 23737 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-03-12-10:43:32-23737 (100642816 bytes)
Comment 1 Mikhail 2012-03-12 05:48:55 EDT
Created attachment 569331 [details]
File: dso_list
Comment 2 Mikhail 2012-03-12 05:48:59 EDT
Created attachment 569332 [details]
File: build_ids
Comment 3 Mikhail 2012-03-12 05:49:06 EDT
Created attachment 569333 [details]
File: maps
Comment 4 Mikhail 2012-03-12 05:49:11 EDT
Created attachment 569334 [details]
File: backtrace
Comment 5 Milan Crha 2012-03-13 03:41:42 EDT
I guess this is the same issue as bug #802306, the common place in the backtrace is Thread 4 there and Thread 8 here, which is identical, under the evolution-mapi call, incomplete backtrace.

*** This bug has been marked as a duplicate of bug 802306 ***
Comment 6 Milan Crha 2012-09-17 09:32:46 EDT
Err, I'm wrong, this is not bug #802306, this is [1]. I'll provide a build of evolution with the upstream patch backported shortly.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=683349
Comment 7 Fedora Update System 2012-09-17 11:04:18 EDT
evolution-3.4.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/evolution-3.4.4-2.fc17
Comment 8 Fedora Update System 2012-09-18 23:00:20 EDT
Package evolution-3.4.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing evolution-3.4.4-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14317/evolution-3.4.4-2.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-27 00:29:20 EDT
evolution-3.4.4-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.