Bug 802326 - Detect and use proper path for lvm binary in 69-dm-lvmetad.rules
Detect and use proper path for lvm binary in 69-dm-lvmetad.rules
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Peter Rajnoha
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 06:01 EDT by Peter Rajnoha
Modified: 2012-06-20 11:02 EDT (History)
11 users (show)

See Also:
Fixed In Version: lvm2-2.02.95-2.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Rajnoha 2012-03-12 06:01:23 EDT
We can't use 'DM_SBIN_PATH' in lvmetad udev rules. This one is set only for dm devices but not for all block devices - the pvscan is run on all relevant block devices and hence the path needs to be always detected properly.

Patch: https://www.redhat.com/archives/lvm-devel/2012-March/msg00090.html
Comment 1 Peter Rajnoha 2012-03-12 06:02:40 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 6 errata-xmlrpc 2012-06-20 11:02:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Note You need to log in before you can comment on or make changes to this bug.