Bug 802374 - Don't reload the page automatically if user go back to the previous page
Don't reload the page automatically if user go back to the previous page
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Red Hat Gecko Maintainer
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 08:07 EDT by Qixiang Wan
Modified: 2012-07-17 10:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 10:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qixiang Wan 2012-03-12 08:07:42 EDT
Description of problem:
Sometimes firefox will reload the page if after users click the go back button. Found this when adding comments to rhbz and there is error prompt after click
save changes.

Version-Release number of selected component (if applicable):
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.24) Gecko/20111104 Red Hat/3.6.24-3.el6_1 Firefox/3.6.24

How reproducible:
100%

Steps to Reproduce:
1. Login redhat bugzilla, open one bug page (suggest you to play with this one).
2. Input some comments to the bug, and select the needinfo checkbox, enter an invalid mail address "xyz@xyz.xyz".
3. Click save changes. Then you will get an error page saying:
"There is no user named 'xyz@xyz.xyz'. Either you mis-typed the name or that user has not yet registered for a Red Hat Bugzilla account."
4. Click "Go back one page" button in the firefox.
5. Wait for several seconds, the page will be reload automatically.
  
Actual results:
step 5. The page is reload automatically, any changes in step 2 will be lost.

Expected results:
The page should not reload automatically.

Additional info:
1. Can be reproduced on F16 with firefox 10.0.1.
2. Can't be reproduced with google-chrome (Linux x86_64 17.0.963.79)

Not sure whether this is a bug, at least failed to find any options to change this behaviour.
Comment 2 RHEL Product and Program Management 2012-05-03 00:41:28 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Martin Stransky 2012-07-17 10:03:49 EDT
I'm unable to reproduce with Firefox 14, seems to be fixed here. We're not going to back port this fix to the ESR line.

Note You need to log in before you can comment on or make changes to this bug.