Bug 802402 - Arquillian BOM file has no enterprise variant
Arquillian BOM file has no enterprise variant
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Arquillian (Show other bugs)
2.0.0.ER3
Unspecified Unspecified
medium Severity medium
: ---
: 2.0.0.ER4
Assigned To: Marek Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 09:36 EDT by Karel Piwko
Modified: 2012-06-22 10:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform had to combine two different BOMs. JBoss Web Framework Kit 2.0.0 now distributes jboss-javaee-6.0-with-tools in enterprise version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 04:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-8418 Critical Closed redhat versions of jboss-javaee-6.0-with-* poms are missing from the maven repo 2013-04-23 05:03:37 EDT

  None (edit)
Description Karel Piwko 2012-03-12 09:36:27 EDT
Description of problem:

Users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform cannot easily switch from community to enterprise variant adding a "-redhat-1" prefix to the version of artifact.

Version-Release number of selected component (if applicable):

1.0.0.M3

How reproducible:

Always.

Steps to Reproduce:
1.
Include following:

<dependencyManagement>
   <dependencies>
      <groupId>org.jboss.bom</groupId>
      <artifactId>jboss-javaee-6.0-with-tools</artifactId>
      <version>1.0.0.M3</version>
      <type>pom</type>
      <scope>import</scope>      
   </dependencies>
</dependencyManagement>

2. Change version to 1.0.0.M3-redhat-1
  
Actual results:

It fails, there is no such artifact

Expected results:

It works.

Additional info:
Comment 1 Karel Piwko 2012-03-12 09:39:49 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform
cannot easily switch from community to enterprise variant adding a "-redhat-1" prefix to the version of artifact, because no such variant exists.

To workaround that, import following BOMs in given order in your project pom.xml file:

<dependencyManagement>
   <dependencies>
      <dependency>
          <groupId>org.jboss.spec</groupId>
          <artifactId>jboss-javaee-6.0</artifactId>
          <version>3.0.0.Beta1-redhat-1</version>
          <type>pom</type>
          <scope>import</scope>      
      <dependency>
      <dependency>
          <groupId>org.jboss.bom</groupId>
          <artifactId>jboss-javaee-6.0-with-tools</artifactId>
          <version>1.0.0.M3</version>
          <type>pom</type>
          <scope>import</scope>      
      <dependency>
   </dependencies>
</dependencyManagement>
Comment 2 JBoss JIRA Server 2012-03-26 16:09:28 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBPAPP-8418

This issue is only for tracking, right now the work will be done in WFK 2 and the missing BOM will be in WFK2 Maven repository.
Comment 3 JBoss JIRA Server 2012-04-20 16:12:57 EDT
Paul Gier <pgier@redhat.com> updated the status of jira JBPAPP-8418 to Resolved
Comment 4 JBoss JIRA Server 2012-04-20 16:12:57 EDT
Paul Gier <pgier@redhat.com> made a comment on jira JBPAPP-8418

All the boms are now included in the Maven repo zip.
Comment 6 Marek Novotny 2012-06-20 04:25:57 EDT
Yes, mentioned BOM are in EAP 6 maven repository only version is different from previous comment #1.
      <dependency>
          <groupId>org.jboss.bom</groupId>
          <artifactId>jboss-javaee-6.0-with-tools</artifactId>
          <version>1.0.0.M12-redhat-1</version>
          <type>pom</type>
          <scope>import</scope>      
      <dependency>
Comment 7 Marek Novotny 2012-06-20 04:27:37 EDT
Forgot to mention first BOM version too
      <dependency>
          <groupId>org.jboss.spec</groupId>
          <artifactId>jboss-javaee-6.0</artifactId>
          <version>3.0.0.Final-redhat-1</version>
          <type>pom</type>
          <scope>import</scope>      
      <dependency>
Comment 9 Karel Piwko 2012-06-22 10:14:31 EDT
Arquillian Enterprise BOM is in WFK 2.0.0.
Comment 10 Karel Piwko 2012-06-22 10:15:56 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,23 +1,3 @@
-Users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform
-cannot easily switch from community to enterprise variant adding a "-redhat-1" prefix to the version of artifact, because no such variant exists.
+Previously, users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform had to combine tow different BOMs.
 
-To workaround that, import following BOMs in given order in your project pom.xml file:
+JBoss Web Framework Kit 2.0.0 now distributes jboss-javaee-6.0-with-tools in enterprise version.-
-<dependencyManagement>
-   <dependencies>
-      <dependency>
-          <groupId>org.jboss.spec</groupId>
-          <artifactId>jboss-javaee-6.0</artifactId>
-          <version>3.0.0.Beta1-redhat-1</version>
-          <type>pom</type>
-          <scope>import</scope>      
-      <dependency>
-      <dependency>
-          <groupId>org.jboss.bom</groupId>
-          <artifactId>jboss-javaee-6.0-with-tools</artifactId>
-          <version>1.0.0.M3</version>
-          <type>pom</type>
-          <scope>import</scope>      
-      <dependency>
-   </dependencies>
-</dependencyManagement>
Comment 11 Karel Piwko 2012-06-22 10:16:56 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,3 +1,3 @@
-Previously, users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform had to combine tow different BOMs.
+Previously, users willing to use jboss-javaee-6.0-with-tools with JBoss Enterprise Platform had to combine two different BOMs.
 
 JBoss Web Framework Kit 2.0.0 now distributes jboss-javaee-6.0-with-tools in enterprise version.

Note You need to log in before you can comment on or make changes to this bug.