Bug 802470 - SELinux is preventing /lib/systemd/systemd-logind from 'read' accesses on the archivo sessionid.
SELinux is preventing /lib/systemd/systemd-logind from 'read' accesses on the...
Status: CLOSED DUPLICATE of bug 802468
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9bcfeb056e607ee94ecf497de43...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 12:10 EDT by Jose Borrego
Modified: 2012-03-12 12:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 12:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Borrego 2012-03-12 12:10:07 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.9-2.fc16.x86_64
reason:         SELinux is preventing /lib/systemd/systemd-logind from 'read' accesses on the archivo sessionid.
time:           lun 12 mar 2012 09:07:31 EDT

description:
:SELinux is preventing /lib/systemd/systemd-logind from 'read' accesses on the archivo sessionid.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-logind should be allowed read access on the sessionid file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_logind_t:s0
:Target Context                system_u:system_r:rpm_script_t:s0-s0:c0.c1023
:Target Objects                sessionid [ file ]
:Source                        systemd-logind
:Source Path                   /lib/systemd/systemd-logind
:Port                          <Desconocido>
:Host                          (removed)
:Source RPM Packages           systemd-37-13.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.9-2.fc16.x86_64 #1 SMP Mon Mar
:                              5 20:55:39 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    lun 12 mar 2012 09:06:24 EDT
:Last Seen                     lun 12 mar 2012 09:06:24 EDT
:Local ID                      b5929d98-e481-4e4a-939a-76803b7acd1c
:
:Raw Audit Messages
:type=AVC msg=audit(1331557584.438:190): avc:  denied  { read } for  pid=884 comm="systemd-logind" name="sessionid" dev=proc ino=70862 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:system_r:rpm_script_t:s0-s0:c0.c1023 tclass=file
:
:
:type=AVC msg=audit(1331557584.438:190): avc:  denied  { open } for  pid=884 comm="systemd-logind" name="sessionid" dev=proc ino=70862 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:system_r:rpm_script_t:s0-s0:c0.c1023 tclass=file
:
:
:type=SYSCALL msg=audit(1331557584.438:190): arch=x86_64 syscall=open success=yes exit=EAGAIN a0=13cfee0 a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=884 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-logind exe=/lib/systemd/systemd-logind subj=system_u:system_r:systemd_logind_t:s0 key=(null)
:
:Hash: systemd-logind,systemd_logind_t,rpm_script_t,file,read
:
:audit2allow
:
:#============= systemd_logind_t ==============
:allow systemd_logind_t rpm_script_t:file { read open };
:
:audit2allow -R
:
:#============= systemd_logind_t ==============
:allow systemd_logind_t rpm_script_t:file { read open };
:
Comment 1 Daniel Walsh 2012-03-12 12:14:00 EDT

*** This bug has been marked as a duplicate of bug 802468 ***

Note You need to log in before you can comment on or make changes to this bug.