Bug 802480 - Update pkg-config to 0.26
Update pkg-config to 0.26
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pkgconfig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 12:36 EDT by Christophe Fergeau
Modified: 2012-12-18 05:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 05:03:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2012-03-12 12:36:02 EDT
f17 and rawhide have pkg-config 0.25. The 0.26 version was released last May and fixes one bug that we just hit when trying to build gnome-boxes:

 - Fix up pkg.m4 to handle the case of --exists working and --cflags
   or --libs failing.

Due to a bug in the spice-gtk package (caused by an rpm bug), the requires for the packages required in spice-gtk .pc files were not automatically added to the spice-gtk development package. This caused the spice-gtk .pc files to require non-existing .pc files, which means pkg-config --exists worked, but pkg-config --cflags --libs failed. Due to the pkg.m4 bug mentioned above, this error didn't appear in the build log, which made things harder to diagnose.
Comment 1 Christophe Fergeau 2012-04-26 04:16:41 EDT
pkg-config 0.26 has been pushed to rawhide.

Note You need to log in before you can comment on or make changes to this bug.