Bug 802518 - Sendmail DaemonPort change from 25
Sendmail DaemonPort change from 25
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sendmail (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 13:50 EDT by Gerry Hynes
Modified: 2012-03-13 05:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 05:05:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Hynes 2012-03-12 13:50:37 EDT
Description of problem:
If you change the DaemonPortOptions=Port=25 to DaemonPortOptions=Port=125 the MTA will not start. You can start the MTA at the command line with "/usr/sbin/sendmail -bd -q1h.


Version-Release number of selected component (if applicable):
Version 6.1

How reproducible:
Everytime.


Steps to Reproduce:
1./etc/init.d/sendmail stop
2.change the DaemonPortOptions=Port=125
3./etc/init.d/sendmail start
  
Actual results:
Looks like it starts, but only the client actually starts.
maillog stats that 
Mar 12 09:42:48 mail sendmail[1828]: starting daemon (8.14.4): SMTP+queueing@01:00:00
Mar 12 09:42:48 mail sendmail[1828]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Permission denied
Mar 12 09:42:48 mail sendmail[1828]: daemon MTA: problem creating SMTP socket
Mar 12 09:42:48 mail sendmail[1828]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting



Expected results:


Additional info:

If you after this enter at the command line as root 

/usr/sbin/sendmail -bd -q1h

Sendmail works fine on port 125.
Comment 2 Jaroslav Škarvada 2012-03-13 05:05:01 EDT
It looks like SELinux, you need to mark your new port as SMTP, i.e. by:

# yum install policycoreutils-python
# semanage port -a -t smtp_port_t -p tcp 125

or disable SELinux (not recommended), one-shot for running session:
# setenforce 0

According to the above I am closing this as NOTABUG. If the problem persists, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.