Bug 802531 - vnstatd service does not run
vnstatd service does not run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vnstat (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 14:32 EDT by bugfinder
Modified: 2012-03-16 03:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-16 03:41:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bugfinder 2012-03-12 14:32:45 EDT
Description of problem:
The init.d script indicates that the service was started successfully but it does not appear in the process list and the vnstat database is never updated.

Version-Release number of selected component (if applicable):
1.11


How reproducible:
Everytime

Additional info:
I've also tried it with SELinux set in permissive mode and the result is the same.

[root@system ~]# service vnstat restart
Restarting vnstat (via systemctl):                         [  OK  ]
[root@system ~]# ps ax | grep vnstat
 3785 pts/1    S+     0:00 grep --color=auto vnstat
[root@system ~]# ls -Zal /var/lib/vnstat
total 16
drwxr-xr-x.  2 system_u:object_r:vnstatd_var_lib_t:s0 vnstat vnstat 4096 Mar 12 23:26 .
drwxr-xr-x. 42 system_u:object_r:var_lib_t:s0   root   root   4096 Mar  7 22:52 ..
-rw-r--r--.  1 unconfined_u:object_r:vnstatd_var_lib_t:s0 vnstat vnstat 2792 Mar 12 23:51 em1
-rw-r--r--.  1 unconfined_u:object_r:vnstatd_var_lib_t:s0 vnstat vnstat 2792 Mar 12 23:51 .em1
Comment 1 Adrian Reber 2012-03-13 04:57:55 EDT
Please specify the exact version of vnstat.
Comment 2 bugfinder 2012-03-13 13:12:13 EDT
vnstat-1.11-2.fc16.x86_64
Comment 3 Adrian Reber 2012-03-15 12:27:10 EDT
Please try vnstat-1.11-6 from updates-testing. It should hit updates soon.
Comment 4 bugfinder 2012-03-16 00:58:17 EDT
Just tried vnstat-1.11-6.

The problem is fixed now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.