Bug 802540 - NetworkManager-vpnc not asking for password with latest update
Summary: NetworkManager-vpnc not asking for password with latest update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 800281 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-12 19:14 UTC by Thomas Woerner
Modified: 2012-03-22 10:18 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-0.9.3.995-0.6.git20120314.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-18 00:46:30 UTC
Type: ---


Attachments (Terms of Use)

Description Thomas Woerner 2012-03-12 19:14:23 UTC
Description of problem:
Since the update to NetworkManager-vpnc-0.9.3.995-1.git20120302.fc17.x86_64, trying to establish a vpnc connection is not working anymore. There is no dialog to enter the password. NetworkManager-vpnc-0.9.0-4.fc17.x86_64 is working as expected.

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.9.3.995-1.git20120302.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Try to establish a vpnc connection in nm-applet.
  
Actual results:
Mar 12 20:06:30 brasilia NetworkManager[630]: <error> [1331579190.106444] [nm-vpn-connection.c:925] get_secrets_cb(): Failed to request VPN secrets #3: (6) No agents were available for this request.

Expected results:
Dialog to enter password.

Comment 1 Dan Williams 2012-03-13 20:19:43 UTC
*** Bug 800281 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2012-03-13 20:46:20 UTC
NetworkManager-0.9.3.995-0.5.git20120313.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.3.995-0.5.git20120313.fc17

Comment 3 Fedora Update System 2012-03-14 18:24:36 UTC
NetworkManager-0.9.3.995-0.6.git20120314.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.3.995-0.6.git20120314.fc17

Comment 4 Fedora Update System 2012-03-16 02:43:47 UTC
Package NetworkManager-0.9.3.995-0.6.git20120314.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.3.995-0.6.git20120314.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3861/NetworkManager-0.9.3.995-0.6.git20120314.fc17
then log in and leave karma (feedback).

Comment 5 Thomas Woerner 2012-03-16 09:47:37 UTC
This is not fixing the problem here.

Fails: NetworkManager-vpnc-0.9.3.995-1.git20120302.fc17.x86_64 
Works: NetworkManager-vpnc-0.9.0-4.fc17.x86_64

Error: Mar 16 10:45:15 brasilia NetworkManager[2679]: <error> [1331891115.638549] [nm-vpn-connection.c:925] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.

Comment 6 Fedora Update System 2012-03-18 00:46:30 UTC
NetworkManager-0.9.3.995-0.6.git20120314.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Thomas Woerner 2012-03-22 10:18:07 UTC
NetworkManager-vpnc-0.9.3.997-1.fc17.x86_64 is working for me.


Note You need to log in before you can comment on or make changes to this bug.