Bug 802547 - RHUI admin should be given the option to remove content durning a "delete repo" action
RHUI admin should be given the option to remove content durning a "delete rep...
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Documentation (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Julie
Martin Kočí
:
: 802545 (view as bug list)
Depends On: 819985
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 15:26 EDT by wes hayutin
Modified: 2016-02-18 01:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Deleting repositories made yum unable to execute the client configuration rpms in those directories. This update added this note to the RHUI Administration Guide.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2012-03-12 15:26:04 EDT
RHUI admin should be given the option to remove content durning a "delete repo" 
action

Content should be cleaned off of the rhui, and when synced to the cds.. content should be cleaned off there as well..

[root@qeblade30 RHUI201-02]# rpm -qa | grep pulp
pulp-admin-0.0.263-18.el6.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
pulp-consumer-0.0.263-18.el6.noarch
pulp-0.0.263-18.el6.noarch
pulp-common-0.0.263-18.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
pulp-selinux-server-0.0.263-18.el6.noarch
pulp-client-lib-0.0.263-18.el6.noarch
mod_wsgi-3.3-2.pulp.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
[root@qeblade30 RHUI201-02]# rpm -qa | grep rhui
rh-rhui-tools-2.0.60-1.el6.noarch
[root@qeblade30 RHUI201-02]# 




rhui (repo) => d

Select one or more repositories:

  Custom Repositories
    -  1 : protected
    -  2 : unprotected

  Red Hat Repositories
    -  3 : Red Hat Enterprise Linux 6 Server from RHUI (RPMs) (6Server-i386)
    -  4 : Red Hat Enterprise Linux 6 Server from RHUI (RPMs) (6Server-x86_64)
    -  5 : Red Hat Update Infrastructure 1.2 (RPMs) (5Server-i386)
    -  6 : Red Hat Update Infrastructure 1.2 (RPMs) (5Server-x86_64)
    -  7 : Red Hat Update Infrastructure 2.0 (RPMs) (6Server-i386)
    -  8 : Red Hat Update Infrastructure 2.0 (RPMs) (6Server-x86_64)

Enter value (1-8) to toggle selection, 'c' to confirm selections, or '?' for more commands: 5
Comment 1 wes hayutin 2012-03-12 15:46:09 EDT
To clarify.. the admin should be given the option when deleting repos whether or not to remove content.


wkflow:
1. delete repo 
2. prompt: delete content of repo y/n?

If y:
repo disabled, and content removed from rhui and cds

If y:
repo disabled, and content left on rhui and cds
Comment 2 James Slagle 2012-05-08 15:32:15 EDT
This bug requires documentation changes for the additional questions asked.  Also, cleaning content off the CDS will need to be a change in Pulp.
Comment 3 James Slagle 2012-05-08 15:36:23 EDT
*** Bug 802545 has been marked as a duplicate of this bug. ***
Comment 4 James Slagle 2012-05-08 15:38:28 EDT
*** Bug 801113 has been marked as a duplicate of this bug. ***
Comment 5 James Slagle 2012-05-29 13:28:10 EDT
need to document that if any clients were configured to use the now deleted repo, they need to be updated.
Comment 6 James Slagle 2012-06-11 21:38:03 EDT
In Section 5.4, Deleting a Repository in the Installation guide, we need to alert the user that when a repository is deleted and after the next CDS sync, any clients that have installed client configuration rpm's that reference the now deleted repository will not be able to use yum since it won't be able to access the deleted repository.  We could probably add this information in another Note like the one we already have there.
Comment 8 Martin Kočí 2012-07-26 07:48:46 EDT
In 2.1 docu, see the note in section 2.4: "Repositories will be deleted only after the next CDS synchronization occurs, and the client configuration rpms that refer to the deleted repositories won't be able to be executed by yum." 
Moving this documentation bug to VERIFIED.
Comment 9 Athene Chan 2012-08-14 20:52:27 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Deleting repositories made yum unable to execute the client configuration rpms in those directories. This update added this note to the RHUI Administration Guide.
Comment 11 errata-xmlrpc 2012-08-24 07:53:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.