This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 802600 - soft lockup when Shutdown the guest after dd [NEEDINFO]
soft lockup when Shutdown the guest after dd
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: 807515 834968
  Show dependency treegraph
 
Reported: 2012-03-12 23:22 EDT by yunpingzheng
Modified: 2013-07-25 05:41 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 807515 834968 (view as bug list)
Environment:
Last Closed: 2013-07-25 05:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
qzhang: needinfo? (yunzheng)


Attachments (Terms of Use)
call trace (3.00 KB, text/plain)
2012-03-13 00:45 EDT, yunpingzheng
no flags Details
call trace-2 (15.95 KB, text/plain)
2012-03-14 02:59 EDT, Suqin Huang
no flags Details
call-trace-info-2012-0719 (53.94 KB, application/octet-stream)
2012-07-19 01:22 EDT, yunpingzheng
no flags Details

  None (edit)
Description yunpingzheng 2012-03-12 23:22:46 EDT
Description of problem:
when  shutdown the guest os  which using raw block[convert from qcow2] will call trace.

Version-Release number of selected component (if applicable):

qemu-kvm-0.12.1.2-2.241.el6.x86_64


How reproducible:
1/100

Steps to Reproduce:
1.Install the guest using qcow2
2.convet the img to raw
    #qemu-img convert -f qcow2 -O raw  /path to *.qcow2  /path to *.raw  
3.boot the guest os using the raw
4.login the guest os ,execute dd and shutdown :
   # dd if=/dev/zero of=/mnt/test bs=1000 count=100
   # shutdown -h now
  
Actual results:
After shutdown the system , it will call trace

Expected results:
shutdown the os ,and not call trace

Additional info:
1. host:
kernel: kernel-2.6.32-250.el6.x86_64

cpu:

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0

flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv

2. guest
rhel6.2.64

3. cmd
qemu-kvm -chardev socket,id=qmp_monitor,path=/tmp/monitor,server,nowait -mon chardev=qmp_monitor,mode=control \
-chardev socket,id=serial,path=/tmp/serial,server,nowait -device isa-serial,chardev=serial \
-device ich9-usb-uhci1,id=usb1,multifunction=off,bus=pci.0,addr=0x4 \
-drive file=converted_raw.raw,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,format=raw,aio=native \
-device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idQsXqNW,mac=9a:09:bb:57:73:0e,id=ndev00idQsXqNW,bus=pci.0,addr=0x3 -netdev tap,id=idQsXqNW,vhost=on,scrip=/etc/qemu-ifup \
-m 2048 -smp 2,cores=1,threads=1,sockets=2\
-cpu cpu64-rhel6,+sse2,+x2apic \
-device usb-tablet,id=usb-tablet1,bus=usb1.0 -vnc :0 -rtc base=utc,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=c,menu=off    -no-kvm-pit-reinjection -enable-kvm

4. call trace is attached
Comment 2 yunpingzheng 2012-03-13 00:45:21 EDT
Created attachment 569548 [details]
call trace
Comment 3 Dor Laor 2012-03-13 10:40:04 EDT
How often that it happens? IMHO it does not have nothing to do w/ the conversion from qcow
Comment 4 Suqin Huang 2012-03-14 02:59:00 EDT
(In reply to comment #3)
> How often that it happens? IMHO it does not have nothing to do w/ the
> conversion from qcow

rarely, test on two hosts, one 1/100, another one 2/100
Comment 5 Suqin Huang 2012-03-14 02:59:42 EDT
Created attachment 569879 [details]
call trace-2
Comment 6 Marcelo Tosatti 2012-03-20 22:43:56 EDT
This is not a softlockup, but an interrupt event on line 11 that the usb-driver did not acknowledge as generated from the USB controller.

As this error is

1) during poweroff, without affecting normal
shutdown functioning.
2) does not cause any practical harm.
3) is very rare.

I would ignore it. 

Gerd might be interested, though, so reassigning to him (Gerd, feel free to
close it if you consider that appropriate).
Comment 7 Gerd Hoffmann 2012-03-21 09:13:18 EDT
Yea, will look into it, seems to be a bug in the uhci emulation.  Given the conditions needed to trigger certainly not 6.3 material though, moving to 6.4.
Comment 8 Gerd Hoffmann 2012-04-20 08:45:39 EDT
Bug 806723 is possibly a dup of this one.
Comment 12 yunpingzheng 2012-05-23 22:01:44 EDT
reproduce in rhel 6.3  qemu-kvm-0.12.1.2-2.295.el6

2012-05-22 23:21:08: Call Trace:
2012-05-22 23:21:08:  <IRQ>  [<ffffffff810db31b>] ? __report_bad_irq+0x2b/0xa0
2012-05-22 23:21:08:  [<ffffffff810db51c>] ? note_interrupt+0x18c/0x1d0
2012-05-22 23:21:08:  [<ffffffff8102da99>] ? ack_apic_level+0x79/0x1b0
2012-05-22 23:21:08:  [<ffffffff810dbc3d>] ? handle_fasteoi_irq+0xcd/0xf0
2012-05-22 23:21:08:  [<ffffffff8100df09>] ? handle_irq+0x49/0xa0
2012-05-22 23:21:08:  [<ffffffff814f4c7c>] ? do_IRQ+0x6c/0xf0
2012-05-22 23:21:08:  [<ffffffff8100ba53>] ? ret_from_intr+0x0/0x11
2012-05-22 23:21:08:  [<ffffffff81071fb0>] ? __do_softirq+0x70/0x1d0
2012-05-22 23:21:08:  [<ffffffff810308de>] ? native_apic_msr_read+0x2e/0x40
2012-05-22 23:21:08:  [<ffffffff8100c24c>] ? call_softirq+0x1c/0x30
2012-05-22 23:21:08:  [<ffffffff8100de85>] ? do_softirq+0x65/0xa0
2012-05-22 23:21:08:  [<ffffffff81071de5>] ? irq_exit+0x85/0x90
2012-05-22 23:21:08:  [<ffffffff814f4c85>] ? do_IRQ+0x75/0xf0
2012-05-22 23:21:08:  [<ffffffff81072b49>] ? r_stop+0x9/0x20
2012-05-22 23:21:08:  [<ffffffff8100ba53>] ? ret_from_intr+0x0/0x11
2012-05-22 23:21:08:  <EOI>  [<ffffffff814f07e0>] ? text_poke+0x160/0x250
2012-05-22 23:21:08:  [<ffffffff814f7185>] ? _etext+0x0/0x3
2012-05-22 23:21:08:  [<ffffffff8101228c>] ? alternatives_smp_unlock+0x9c/0xc0
2012-05-22 23:21:08:  [<ffffffff81012479>] ? alternatives_smp_switch+0x1a9/0x1e0
2012-05-22 23:21:08:  [<ffffffff81278f8c>] ? __bitmap_weight+0x8c/0xb0
2012-05-22 23:21:08:  [<ffffffff8102ab57>] ? native_cpu_die+0x87/0xa0
2012-05-22 23:21:08:  [<ffffffff814d5212>] ? _cpu_down+0x122/0x2c0
2012-05-22 23:21:08:  [<ffffffff8106ba83>] ? disable_nonboot_cpus+0xa3/0x120
2012-05-22 23:21:08:  [<ffffffff81088d66>] ? kernel_power_off+0x26/0x40
2012-05-22 23:21:08:  [<ffffffff81089061>] ? sys_reboot+0x111/0x220
2012-05-22 23:21:08:  [<ffffffff8118d0bf>] ? __d_free+0x3f/0x60
2012-05-22 23:21:08:  [<ffffffff8118d138>] ? d_free+0x58/0x60
2012-05-22 23:21:08:  [<ffffffff81195630>] ? mntput_no_expire+0x30/0x110
2012-05-22 23:21:08:  [<ffffffff81177dd1>] ? __fput+0x1a1/0x210
2012-05-22 23:21:08:  [<ffffffff8100b0f2>] ? system_call_fastpath+0x16/0x1b
2012-05-22 23:21:08: handlers:
2012-05-22 23:21:08: [<ffffffff8139b490>] (usb_hcd_irq+0x0/0x90)
2012-05-22 23:21:08: Disabling IRQ #11
2012-05-22 23:21:08: Power down.
Comment 17 yunpingzheng 2012-07-19 01:22:49 EDT
Created attachment 599068 [details]
call-trace-info-2012-0719
Comment 20 Ronen Hod 2013-07-25 05:14:53 EDT
Closing.
Unlikely to be fixed in RHEL6.
Please test with RHEL7, and file a new BZ
Comment 21 Qunfang Zhang 2013-07-25 05:24:03 EDT
Hi, Yunping
Could you help test with RHEL7 and file new BZ if have problem? 

Thanks!

Note You need to log in before you can comment on or make changes to this bug.