Bug 802623 - Only can detect 2 processors in the guest when using -smp 4 on my host
Only can detect 2 processors in the guest when using -smp 4 on my host
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks: 833130
  Show dependency treegraph
 
Reported: 2012-03-13 01:42 EDT by Mike Cao
Modified: 2013-05-30 11:10 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 11:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screendump for cpu-z (28.85 KB, image/png)
2012-03-13 01:51 EDT, Mike Cao
no flags Details
WHQL NDIS CHECK_CONFIG log only detects 2 processors (48.64 KB, text/html)
2012-03-13 01:53 EDT, Mike Cao
no flags Details
Screendump for EVEREST (47.61 KB, image/png)
2012-03-13 02:14 EDT, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2012-03-13 01:42:47 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.6.32-232.el6.x86_64
qemu-kvm-0.12.1.2-2.236.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Start guest with -cpu rhel6-cpu64,family=0xf,+x2apic ,-smp 4 
GLI :
0:01:33 /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu cpu64-rhel6,+x2apic,family=0xf -enable-kvm -m 6G -smp 4 -name win2k8-mike-r2 -uuid 2a39c87a-18b4-b9bc-c022-a4ca069391f1 -rtc base=localtime,clock=host,driftfix=slew -drive file=/mike/win2k8-r2.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/home/mike/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:bd:6f:d6,bus=pci.0,addr=0x3 -netdev tap,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=52:54:00:bd:62:34,bus=pci.0 -netdev tap,id=hostnet2,vhost=on -device virtio-net-pci,netdev=hostnet2,id=net2,mac=52:54:00:bd:6f:28,bus=pci.0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -usb -device usb-tablet,id=input0 -spice port=5931,disable-ticketing -vga qxl -balloon none -bios /root/bios-tttt.bin -monitor unix:/tmp/win2k8-mike-r2.monitor,server,nowait
2.Run cpu-z in the guest
3.Run WHQL NDIS ConfigCheck job 
  
Actual results:
After step2 ,only 2 processors could be detected 
After step3 ,only 2 processors could be detected and cause my WHQL job failed with "For running logo tests for devices should have atlease 4 processors "

Expected results:
Both 2 steps should detects 4 processors .

Additional info:
1.Host CPU info 
#cat /proc/cpuinfo
processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
stepping	: 7
cpu MHz		: 3092.716
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 6
initial apicid	: 6
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 x2apic popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6185.15
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

2.(qemu)info cpus
(qemu) info cpus 
* CPU #0: pc=0xfffff8000161d17e thread_id=555 
  CPU #1: pc=0xfffff88002ef39c2 (halted) thread_id=556 
  CPU #2: pc=0xfffff88002ef39c2 (halted) thread_id=557 
  CPU #3: pc=0xfffff88002ef39c2 (halted) thread_id=558
Comment 2 Mike Cao 2012-03-13 01:51:49 EDT
Created attachment 569557 [details]
Screendump for cpu-z
Comment 3 Mike Cao 2012-03-13 01:53:02 EDT
Created attachment 569558 [details]
WHQL NDIS CHECK_CONFIG log only detects 2 processors
Comment 4 Mike Cao 2012-03-13 01:54:41 EDT
Tried with -cpu Westmere as well ,also hit this issue .
Comment 5 Mike Cao 2012-03-13 02:13:07 EDT
Tried with EVEREST Corporation Editiion .
in Multi CPU times line ,it can detects 4 vCPUS (Will attach screendump)
in CPU Utilization Line ,it only can detects 2 vcpu
in windows task manager ,and device manager I could see 4vcpus 

Report this bug because the WHQL NDIS Test Checkconfig job could only detected 2 cpus which cause my job failed
Comment 6 Mike Cao 2012-03-13 02:14:20 EDT
Created attachment 569562 [details]
Screendump for EVEREST
Comment 10 langfang 2013-05-30 06:01:18 EDT
Test this bug as following version ,but can not reproduce on old and latest version.

Old version:
Host
# uname -r
2.6.32-279.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.207.el6.x86_64

Guest:win2008r2

Steps:
1.Boot guest 
# /usr/libexec/qemu-kvm -M rhel6.2.0 -cpu  cpu64-rhel6,+x2apic,family=0xf -enable-kvm -m 6G -smp 4 -name win2k8-mike-r2 -uuid 2a39c87a-18b4-b9bc-c022-a4ca069391f1 -rtc base=localtime,clock=host,driftfix=slew -drive file=/home/win2008r2-64-virtio.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:bd:6f:d6,bus=pci.0,addr=0x3 -netdev tap,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=52:54:00:bd:62:34,bus=pci.0 -netdev tap,id=hostnet2,vhost=on -device virtio-net-pci,netdev=hostnet2,id=net2,mac=52:54:00:bd:6f:28,bus=pci.0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -usb -device usb-tablet,id=input0 -spice port=5931,disable-ticketing -vga qxl -balloon none  -monitor stdio

2.Run cpu-z in the guest

Results:

After step 2,could detects 4 processors .

Addtional info:

Tried boot guest with "-smp 8" ,work OK 

 
Test on latest version:
Host
# uname -r
2.6.32-382.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.371.el6.x86_64
 
Guest:win2008r2

Steps as same as above

Results:
Boot with "-smp 4"--->4 processors could be detected
Boot with "-smp 8"--->8 processors could be detected
Comment 11 Eduardo Habkost 2013-05-30 11:10:59 EDT
Thanks for testing. The problem seems to have been fixed by the topology fixes that are in RHEL-6.4 (see the bug 833130 tracker depencies for the list). Closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.