Bug 802684 - xdm, lxdm, slim: can't login to X session
xdm, lxdm, slim: can't login to X session
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-03-13 05:43 EDT by Jaroslaw Gorny
Modified: 2013-07-31 23:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-31 23:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Gorny 2012-03-13 05:43:11 EDT
Description of problem:
I tried to replace gdm with some lighter replacement as I'm not using GNOME.
I've tried xdm, lxdm, slim. All of them fail to authorize me. After giving user/password, I'm back in login screen.

Version-Release number of selected component (if applicable):
I'm not sure if it is ConsoleKit issue. Just don't know where to post it.
rpm version: ConsoleKit-0.4.5-2.fc17.i686

How reproducible:

Steps to Reproduce:
1. install xdm, lxdm, slim
2. change DISPLAYMANAGER= variable in /etc/sysconfig/desktop
3. logout and try to login again using new DM
Actual results:
Authorization fails (user is presented login screen again).

Expected results:
Successfull login (X session started).

Additional info:
Comment 1 Lennart Poettering 2012-03-13 08:33:27 EDT
Please provide the last 50 lines of /var/log/auth.log!
Comment 2 Jaroslaw Gorny 2012-03-13 10:17:34 EDT
[root@masala ~]# ls -al /var/log/auth*
ls: cannot access /var/log/auth*: No such file or directory
Comment 3 Lennart Poettering 2012-03-15 10:05:07 EDT
(In reply to comment #2)
> [root@masala ~]# ls -al /var/log/auth*
> ls: cannot access /var/log/auth*: No such file or directory

Oops, sorry, meant /var/log/security
Comment 4 Paul Smith 2012-07-29 14:22:50 EDT
I am experiencing the same problem with LXDM and XFCE. I have discovered that by doing 


before trying to login enables a successful login.

Comment 5 Fedora End Of Life 2013-07-03 19:56:25 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2013-07-31 23:05:25 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.