Bug 802699 - misaligned error messages appeared when trying to create/rename namespace with illegal names
misaligned error messages appeared when trying to create/rename namespace wit...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Steve Goodwin
libra bugs
:
Depends On:
Blocks: 808229
  Show dependency treegraph
 
Reported: 2012-03-13 06:06 EDT by Meng Bo
Modified: 2015-05-14 21:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhc-site-0.89.9-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rename_with_existing (49.44 KB, image/png)
2012-03-13 06:06 EDT, Meng Bo
no flags Details
create_with_overlength (44.64 KB, image/png)
2012-03-13 06:07 EDT, Meng Bo
no flags Details
devenv_1670 (47.32 KB, image/png)
2012-03-22 22:08 EDT, Meng Bo
no flags Details

  None (edit)
Description Meng Bo 2012-03-13 06:06:55 EDT
Created attachment 569620 [details]
rename_with_existing

Description of problem:
misaligned error messages appeared when trying to create/rename domain with existing name, blank name, over length name, invalid name.

Version-Release number of selected component (if applicable):
rhc-site-0.88.4-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1.login to openshift website
2.go to /app/account page
3.try to create/rename namespace with illegal names.
  
Actual results:
misaligned error messages appeared

Expected results:
the error messages should show without UI issues.

Additional info:
see attachments for reference.
Comment 1 Meng Bo 2012-03-13 06:07:48 EDT
Created attachment 569621 [details]
create_with_overlength
Comment 2 Xiaoli Tian 2012-03-13 06:56:28 EDT
It seems this error "Your namespace must be letters or numbers with no spaces or symbols." will always there once you have a failure while creating domain.
Comment 3 Clayton Coleman 2012-03-13 15:04:23 EDT
This is what I was referring to earlier - looks like help-inline in this form wants to be left aligned, but it's not clear that it should.  What does bootstrap do?
Comment 4 Steve Goodwin 2012-03-20 10:42:48 EDT
(In reply to comment #3)
> This is what I was referring to earlier - looks like help-inline in this form
> wants to be left aligned, but it's not clear that it should.  What does
> bootstrap do?

<p class="help-inline">... should be within input-prepend-append div, currently it's not. This will align short messages to the right. Additional messages that are longer will clear left and appear left aligned, which would be appropriate.


Looking at _form.html.haml I'm not sure how to position help-inline to be within that div.
Comment 5 Steve Goodwin 2012-03-20 10:54:07 EDT
ok fix is committed
Comment 6 Meng Bo 2012-03-22 22:08:22 EDT
checked on devenv_1670,
The message "Your namespace must be letters or numbers with no spaces or symbols." stay there forever.
But the error message still not align to the left.

Please refer to attachment.
Comment 7 Meng Bo 2012-03-22 22:08:52 EDT
Created attachment 572124 [details]
devenv_1670
Comment 8 Yujie Zhang 2012-03-27 02:31:17 EDT
(In reply to comment #5)
Tested this issue on devenv_1674, the error message aligned to the left on Chrome17,but on firefox10,still has this issue. And the message "Your namespace must be letters or numbers with no spaces or symbols." will there forever,is this expected?
Comment 9 Fabiano Franz 2012-03-29 16:04:45 EDT
Fixed.
Comment 10 Yujie Zhang 2012-03-30 03:42:15 EDT
(In reply to comment #9)
Verify this bug on devenv-stage_154, it has been fixed now.

Note You need to log in before you can comment on or make changes to this bug.