Bug 802772 - Scalability Testing: conductor/deployments shows only 30 rows ... no link or indication that more deployments exist
Scalability Testing: conductor/deployments shows only 30 rows ... no link or ...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.2
: ---
Assigned To: Imre Farkas
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 09:28 EDT by Ronelle Landy
Modified: 2012-12-04 09:58 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The scale-testing of a 100+ applications/instances deploying resulted in a display of only 30 items on the Monitor page while all were running. This bug fix updates Conductor and paginates the results so that all running applications/instances are viewable by clicking the previous, next, and page number buttons.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:58:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Top of conductor/deployments screen (275.42 KB, image/png)
2012-03-13 09:31 EDT, Ronelle Landy
no flags Details
Bottom of conductor/deloyments screen (284.41 KB, image/png)
2012-03-13 09:31 EDT, Ronelle Landy
no flags Details
with Pagination (144.61 KB, image/png)
2012-09-20 16:27 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-03-13 09:28:45 EDT
Description of problem:

101 applications/instances were deployed to the same mock provider from one Conductor instance. All the instances are still in a 'running' state. If a user clicks on the conductor/deployments tab, the users sees only 30 of these active deployments. There is no indication that there are more to be viewed (like a link to page 2 or a double arrow or a 'viewing 30 of 101 applications' text).

(see attached screenshots)

As an example, in the attached screenshots, the user logged in has launched 2 of the 101 applications - only one is currently visible. Searching for the other application does work though :).

By contrast all 200 active users can be viewed on a single page by accessing conductor/users.

How reproducible:


Steps to Reproduce:
1. Launch more than 30 instances from one conductor
2. Click on conductor/deployments
3. See that only 30 are visible
4. No link to further deployments


Versions tested:

rpm -qa |grep aeolus
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
aeolus-conductor-doc-0.8.0-41.el6.noarch
Comment 1 Ronelle Landy 2012-03-13 09:31:02 EDT
Created attachment 569680 [details]
Top of conductor/deployments screen
Comment 2 Ronelle Landy 2012-03-13 09:31:42 EDT
Created attachment 569681 [details]
Bottom of conductor/deloyments screen
Comment 3 Hugh Brock 2012-03-19 13:19:19 EDT
Another pagination issue. 1.0.z.
Comment 4 Imre Farkas 2012-03-20 12:50:24 EDT
Patch has been posted: https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009652.html
Comment 5 Imre Farkas 2012-03-21 09:58:00 EDT
This issue has been fixed. Please verify the commits: 5893ff7eac0f5b3fcc3e7769d0f642939570b13f, 81e7d84949d5bd93827272344b2a3f6c82cd96f2 and 13150b173efb856564bda68498cf826339a985c3
Comment 6 Imre Farkas 2012-03-21 11:09:37 EDT
This fix also belongs to the series: ed2d9e887df3cb30639417eb0d342a3d7d9d39e6
Comment 9 Ronelle Landy 2012-09-20 16:27:05 EDT
Testing rpms:

>>  rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

conductor/deployments now uses pagination ... all instances are visible to the user through multiple pages ... see attached screenshot.

Marking this BZ verified.
Comment 10 Ronelle Landy 2012-09-20 16:27:40 EDT
Created attachment 615113 [details]
with Pagination
Comment 13 errata-xmlrpc 2012-12-04 09:58:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.