Bug 802784 - make repodiff handle local repos even without the file:// prefix
make repodiff handle local repos even without the file:// prefix
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: James Antill
Karel Srot
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 09:58 EDT by Karel Srot
Modified: 2014-10-14 00:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: yum-utils-1.1.30-23.el6
Doc Type: Bug Fix
Doc Text:
NO DOCS NEEDED
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:37:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-03-13 09:58:22 EDT
Description of problem:

repodiff manpage contains:

EXAMPLES
       Compare source pkgs in two local repos:
              repodiff --old=/tmp/repo-old --new=/tmp/repo-new

       Compare x86_64 compat. binary pkgs in two remote repos, and  two  local
       one:
              repodiff    -a     x86_64     --old=http://example.com/repo1-old
              --old=/tmp/repo-old           --new=http://example.com/repo1-new
              --new=/tmp/repo-new

       Compare x86_64 compat. binary pkgs, but also compare arch:
              repodiff    -a    x86_64    --compare-arch    --old=http://exam-
              ple.com/repo1-old     --old=/tmp/repo-old     --new=http://exam-
              ple.com/repo1-new --new=/tmp/repo-new



But the local repos should be specified as file:///tmp/repo-old. Simple /tmp/repo-old is not valid.


Version-Release number of selected component (if applicable):
yum-utils-1.1.30-11.el6
Comment 2 Suzanne Yeghiayan 2012-05-18 16:52:37 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 James Antill 2013-04-09 17:41:28 EDT
I fixed this upstream by fixing the code instead:

commit ec05547a9bb900f01ee0261f0e8c456101605fe2
Author: James Antill <james@and.org>
Date:   Tue Apr 9 17:40:16 2013 -0400

    Allow --old=/foo urls for repodiff.

diff --git a/repodiff.py b/repodiff.py
index c16c03e..003294c 100755
--- a/repodiff.py
+++ b/repodiff.py
@@ -53,6 +53,8 @@ class DiffYum(yum.YumBase):
         newrepo.name = repoid
         if baseurl.startswith("mirror:"):
             newrepo.mirrorlist = baseurl[len("mirror:"):]
+        elif baseurl.startswith("/"):
+            newrepo.baseurl = ["file:" + baseurl]
         else:
             newrepo.baseurl = [baseurl]
         newrepo.basecachedir = self.dy_basecachedir
Comment 6 RHEL Product and Program Management 2013-10-13 20:45:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2014-10-14 00:37:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1411.html

Note You need to log in before you can comment on or make changes to this bug.