Bug 802803 - Evolution Crashes with X11 error
Evolution Crashes with X11 error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 10:26 EDT by Nathan Crubel
Modified: 2012-03-15 11:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-15 11:14:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Crubel 2012-03-13 10:26:27 EDT
Description of problem:
When moving around email in evolution, evolution crashes with the following error in debug file.

(evolution:22971): Gdk-WARNING **: The program 'evolution' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 120418 error_code 11 request_code 12 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Version-Release number of selected component (if applicable):

evolution-3.2.3-1.fc16.i686
evolution-mapi-3.2.3-1.fc16.i686
evolution-data-server-3.2.3-2.fc16.i686
xorg-x11-server-Xorg-1.11.4-1.fc16.i686
xorg-x11-server-common-1.11.4-1.fc16.i686


Steps to Reproduce:
1. Open Evolution
2.  Go though Email
3.
  
Actual results:
Evolution will close.

Expected results:


Additional info:  I am  using Evolution on Fedora 16, KDE 4.8.
Comment 1 Milan Crha 2012-03-13 15:04:25 EDT
Thanks for a bug report. Does the crash provide also any kind of a backtrace, please? Like when it's caught by ABRT or similar bug reporting tool? It will be good to receive such backtrace, to see where it crashed, which may help to figure out why it crashed.
Comment 2 Nathan Crubel 2012-03-14 11:50:32 EDT
No it does not.  It has been having no problems today.  So I am wondering if there was an issue with the exchange which was causing it issues.  But the error above seems weird saying it was an X error.
Comment 3 Nathan Crubel 2012-03-14 15:41:36 EDT
No it does not.  It has been having no problems today.  So I am wondering if there was an issue with the exchange which was causing it issues.  But the error above seems weird saying it was an X error.
Comment 4 Milan Crha 2012-03-15 03:44:26 EDT
I agree, the error itself is weird. I was thinking of the evolution-mapi (or anything below it) issue too, though the backtrace itself doesn't show it begin involved at all in time of the crash. Of course, it could happen earlier and only after this the crash happened. I also reacall an issue in gtk3, which wrote NULL to already freed memory, which can be already occupied by another object. This is fixed in this update (and any later):
https://admin.fedoraproject.org/updates/FEDORA-2012-1720/

Nonetheless, I'm only guessing here. I would wait for couple more days, and if you'll not receive any other similar crash, then let's close this. I'm afraid that finding a reproducible steps (or any clues what can cause this) will be pretty hard.
Comment 5 Nathan Crubel 2012-03-15 11:14:11 EDT
I have not had a problem with Evolution for the last couple of days and have not seen that error since.  I did see it when reported on two machines.  Since then no more issues.  Closing ticket.

Note You need to log in before you can comment on or make changes to this bug.