Bug 802805 - node.js is showing under current control panel
node.js is showing under current control panel
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 10:30 EDT by Anderson Silva
Modified: 2015-05-14 21:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhc-site-0.88.4-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anderson Silva 2012-03-13 10:30:46 EDT
Description of problem:
Under 'Create an App' at: https://openshift.redhat.com/app/control_panel

node.js is showing up as a type, but it is not currently supported yet.

If someone picks that type, the error message:

Invalid application type (-t|--type) specified: ''. Valid application types are (jbossas-7, python-2.6, jenkins-1.4, ruby-1.8, raw-0.1, php-5.3, perl-5.10). 

is displayed.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. login to openshift.redhat.com
2. click on control panel
3. try to create an app of type node.js
  
Actual results:

Invalid application type (-t|--type) specified: ''. Valid application types are (jbossas-7, python-2.6, jenkins-1.4, ruby-1.8, raw-0.1, php-5.3, perl-5.10). 

Expected results:
option node.js should not be there.

Additional info:
Comment 1 Fabiano Franz 2012-03-13 14:08:19 EDT
Fixed.
Node.JS will now appear in all environments (including staging), *except* production. This way we can test it before it goes live.
Comment 2 Xiaoli Tian 2012-03-15 05:59:49 EDT
Nodejs appears in devenv and stage.

But not sure if your fix is deployed to production,for nodejs is still in production control panel, will we deploy it now or wait for the next release ?
Comment 3 Yujie Zhang 2012-03-16 04:12:09 EDT
Since nodejs application can be created successfully devenv-stage_144, this bug is verified.

Note You need to log in before you can comment on or make changes to this bug.